No new node possible



  • But even when I set FHEM to inclusion_mode = 1, I get this error.
    I would assume that the node finds the parent without a running controller if the node ID and parent ID are static.



  • You already tried to restart the node after turning inclusion mode on?
    As long as the parent node is present, the node will send it's messages towards this one, but I'm not sure if this (esp. the presentation()) really needs the controller to answer accordingly.
    Other: are you using MQTT?



  • Yes I also tried to restart the node when inclusing mode is on and I don't use MQTT.



  • Don't have no further idea, but maybe it is really HW-related wrt to this post: https://forum.mysensors.org/topic/6063/solved-mqtt-esp8266-gateway-issue.
    Indicates some kind of incompability between the MySensors-libs 2.1.1 and the Wemos D1 mini defs, other variants of the ESP8266 may be affected, too. MySensors versions between 2.0.0-beta and 2.1.1 have issues with the nrf-part, so downgrading is not the best idea either.
    Do you have the possibility to make tests with a serial GW or at least use the WIFI-GW in a "fake serial mode" (don't really know whether this is possible or not)?



  • So the other thread mentions to go back to 2.0.0
    I will try this today and give feedback.



  • When downgrading I would expect trouble wrt. to the nrf part (other thread is about other RF-chip). Did you try to use the GW as fake serial GW or at least tried to analyse serial output more in depth?
    Btw.: Another user reported having trouble including new nodes with a network-GW, see here: https://forum.mysensors.org/topic/6149/ethernet-gateway-shows-up-on-vera-but-doens-t-want-to-include-devices. As this is the 3rd in very short time, most likely problems will be solved pretty soon.

    EDIT: found even a 4th, pretty similar one: https://forum.mysensors.org/topic/6118/problem-connecting-to-gateway

    Pretty astonishing, because the recent days I built a RS485-GW using the 2.1.1-libs without trouble wrt. including some testnodes in FHEM.
    the only problems I ran into where the neccessity to assingne node ID's manually and I had to restart the other serial GW; this one stopped receiving regular updates from my nrf-nodes.
    Very strange...



  • And here is a 5th similar issue I believe: https://forum.mysensors.org/topic/6147/tsm-fpar-no-reply



  • Thanks for your support. For me it seems that we have some general problems at the moment.

    I will try the following things later:

    #define MY_NODE_ID 10
    #define MY_PARENT_NODE_ID 0
    #define MY_PARENT_NODE_IS_STATIC
    
    1. use dev version of 2.1.1

    2. downgrade to 2.0.0 or less to check if the hardware is working without any problems

    3. use a serial gateway or try to use my WeMos in serial mode


    These are the topics with a similar error (just as a summary for myself):
    https://forum.mysensors.org/topic/6147/tsm-fpar-no-reply
    https://forum.mysensors.org/topic/6118/problem-connecting-to-gateway
    https://forum.mysensors.org/topic/6063/solved-mqtt-esp8266-gateway-issue


    Edit: does anybody have an idea how to use a ESP as serial gateway?



  • Wrt to using the ESP as serial GW: I only did some short test some time ago, but the serial output seemed to be pretty similar to what I would expect from a regular serial GW. So I would at first just rty to use the USB port and change the definition in FHEM.

    You could also try to use the dev version before downgrading. At first look, there seems not to be a specific fix wrt. this problem, but you never know...



  • I did not flash all my nodes with a static node ID and now all new nodes can join the network and are visible in FHEM.

    #define MY_NODE_ID 10
    #define MY_PARENT_NODE_ID 0
    

    I think there is any problem with my WeMos gateway. I will analyze this more in detail, when I have some more time.


Log in to reply
 

389
Online

6.7k
Users

7.6k
Topics

80.5k
Posts

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.