RFM69HW 433 communication problem


  • Mod

    I am now making my rfm69 network to be added to the nrf24 I set up some time ago.
    I can't get node and GW to communicate properly: I tried RPI ethernet gateway and I never received anything on GW, I tried to make a USB gateway using EasyPCB for rfm69 and a node with the rfm69 shield I found on Openhardware also with new driver enabled and I am getting something on the GW

    0;255;3;0;9;0 MCO:BGN:INIT GW,CP=RPNGA---,VER=2.2.0-beta
    0;255;3;0;9;59 TSM:INIT
    0;255;3;0;9;65 TSF:WUR:MS=0
    0;255;3;0;9;75 TSM:INIT:TSP OK
    0;255;3;0;9;83 TSM:INIT:GW MODE
    0;255;3;0;9;92 TSM:READY:ID=0,PAR=0,DIS=0
    0;255;3;0;9;102 MCO:REG:NOT NEEDED
    0;255;3;0;14;Gateway startup complete.
    0;255;0;0;18;2.2.0-beta
    0;255;3;0;9;114 MCO:BGN:STP
    0;255;3;0;9;137 MCO:BGN:INIT OK,TSP=1
    0;255;3;0;9;1169 TSF:MSG:READ,253-253-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    0;255;3;0;9;1187 TSF:MSG:BC
    0;255;3;0;9;1196 TSF:MSG:FPAR REQ,ID=253
    0;255;3;0;9;1208 TSF:CKU:OK,FCTRL
    0;255;3;0;9;1216 TSF:MSG:GWL OK
    0;255;3;0;9;2734 !TSF:MSG:SEND,0-0-253-253,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=NACK:0
    0;255;3;0;9;14409 TSF:MSG:READ,253-253-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    0;255;3;0;9;14428 TSF:MSG:BC
    0;255;3;0;9;14436 TSF:MSG:FPAR REQ,ID=253
    0;255;3;0;9;14448 TSF:PNG:SEND,TO=0
    0;255;3;0;9;14456 TSF:CKU:OK
    0;255;3;0;9;14465 TSF:MSG:GWL OK
    0;255;3;0;9;15962 !TSF:MSG:SEND,0-0-253-253,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=NACK:0
    0;255;3;0;9;17516 TSF:MSG:READ,253-253-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    0;255;3;0;9;17534 TSF:MSG:BC
    0;255;3;0;9;17543 TSF:MSG:FPAR REQ,ID=253
    0;255;3;0;9;17555 TSF:CKU:OK,FCTRL
    0;255;3;0;9;17563 TSF:MSG:GWL OK
    0;255;3;0;9;19054 !TSF:MSG:SEND,0-0-253-253,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=NACK:0
    0;255;3;0;9;20621 TSF:MSG:READ,253-253-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    0;255;3;0;9;20641 TSF:MSG:BC
    0;255;3;0;9;20649 TSF:MSG:FPAR REQ,ID=253
    0;255;3;0;9;20660 TSF:CKU:OK,FCTRL
    0;255;3;0;9;20670 TSF:MSG:GWL OK
    0;255;3;0;9;22218 !TSF:MSG:SEND,0-0-253-253,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=NACK:0
    0;255;3;0;9;23730 TSF:MSG:READ,253-253-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
    

    Any suggestion on what to look for? I am using the same 3cm coil spring antenna on all the nodes/GW; I used 10uF ceramic caps instead of the smaller suggested because I had a bunch of those; on the GW I tried to power it with either step-up booster and a voltage regulator
    These are the defines I added to the default sketches

    #define MY_RADIO_RFM69
    #define MY_IS_RFM69HW
    #define MY_RFM69_NEW_DRIVER
    #define MY_RFM69_TX_POWER_DBM      (10)
    #define MY_RFM69_FREQUENCY        RFM69_433MHZ
    

    BTW, how do you enable new driver for RPI GW?


  • Mod

    @gohan I don't know about the other stuff, but for rpi, see https://www.mysensors.org/build/raspberry#advanced to set the define.


  • Hardware Contributor

    @gohan - as i mentioned in the PM, did you try to change antenna and/or direct solder it to the RFM module?
    The issues I had with reception (NACK) was either the antenna and/or the includes before I got it working. I soldered a SMA connector and this antenna.

    What does your node looks like? NACK as well or No reply? Code?

    This was posted in another thread... maybe a good try?


  • Mod

    I'm using the mock sensors sketch. The node just doesn't get any reply. I'll try with the 17cm wire antenna.


  • Hardware Contributor

    @gohan - I have made a second node to test the DIY antenna.
    It works good (on my bench, have not tested range) as you can see in my logs.

    Im running MySensors dev (not the latest... but updated a couple of weeks ago) with a Serial RFM69 GW (both node and GW are build on EasyPCB.

    I tried both 3.3v regulated and 5v with a voltage regulator.
    Here are some images if my build... I hope they can give you some ideas.
    (REG are shorted due to I used 3.3 regulated voltage as well - this does not affect anything using 5v).

    0_1502551471422_1.JPG
    0_1502551475136_2.JPG
    0_1502551480648_3.JPG
    0_1502551483392_4.JPG
    0_1502551486914_5.JPG

    I would suggest you do a continuity test from all the pins to the right pins on the pro mini, just to make sure they are connected. It is not that easy to solder the SMD pads on the RFM radio as the pins on the Nrf24l01+. You cant tell if they are ok since they are not visible all the way because of the module. First thing that happened was that the radio would not initialise, and I had to "re-flow", heat the pads up again so everything connected. It was not visible and impossible to see the bad connection.

    I would also measure voltage over all important parts. Also make sure you do a continuity test from the top of your antenna to the ANT on the RFM module.


  • Mod

    I did continuity check on all pins and antenna, everything seems fine. It seems there is something on the nodes that can't receive or the gateway can't send


  • Hardware Contributor

    @gohan - ok... strange!
    As I mentioned in PM, I use the W and not HW version... i dont know if thats the case, but let me order some HW modules and I will check!

    Could you upload a picture of your hardware? Maybe I can spot something?


  • Hardware Contributor

    This post is deleted!

  • Mod

    0_1502641993422_IMG_20170813_182005.jpg


  • Hardware Contributor

    Do you get the same log on all boards? They are initialised but then...? No reply or NACK?
    I would use the board with the least connections for GW and power the GW with a rock solid 3.3v.
    With the GW i would use the SMA connector with a bought antenna to be sure...


  • Mod

    Yes, they all get no reply.
    I don't have the SMA nor the right antenna at the moment.
    I am also using one of those MB102 for 3.3v supply, but nothing changes. I'll try with a beefier voltage regulator


  • Hardware Contributor

    @gohan said in RFM69HW 433 communication problem:

    MB102

    Should be enough... a really though one this!
    My bet would be the antennas though... and the GW antenna is offcource the most important. I would focus on that (without I can promise that is the problem).


  • Mod

    I tried the coiled wire like the one you are using, it didn't change at all. I am running out of options unless there is a problem with the rfm modules.


  • Mod

    I got the new batch of 4 new rfm69h but I am still getting no communication between gw and node, now I can't even get some messages received from gw. I have updates to latest development library and used pretty much all defaults values besides setting the right frequency. Unless I'm doing something really wrong, there must be something wrong in the basics. I'll have to try some more combinations with the antennas, but I am really starting to get discouraged since the nrf24 worked fine since the beginning.


  • Hardware Contributor

    @gohan - If you have 3.3v on the radio and the arduino, are sure about the software/sketch then I would also suggest trying different antennas. What are you using today? I would buy a SMA connector and a good antenna. Even though I have the DIY antenna on the test-node above, I still have a factory antenna + SMA connector on the gw.



  • I'm not very familiar with that hardware, but from a cursory glance it looks like you don't have the interrupt pin connected? Unlike the NRF modules, the RFM69s are interrupt-driven and need DIO0 connected to pin 2


  • Mod

    I am waiting for the antennas and sma connectors too. Irq pin i think it is connected as it should be in the in the pcb.


  • Hardware Contributor

    @Carywin - its EasyPCB RFM edition and D2 is connected to DIO0 pin as described in the radio tutorial so unless he is using a strange RFM module with the interrupt pin on some different place that should work.



  • Right, I'm sure that node is fine, I mainly just zoomed in and looked at this one:
    0_1505086819240_IMG_4281.JPG
    I use this same small piggyback board for many nodes and it works great with those 21mm coil antennas.

    However, I just noticed the #define for TX power. I think the H and HW versions have a minimum of 13dB or something. Have you tried without?



  • @gohan a straight pig tail antenna of about 30mm should work fine (but will not be perfectly tuned).


Log in to reply
 

309
Online

6.7k
Users

7.6k
Topics

80.4k
Posts

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.