Log Translation



  • Still trying to get my 1st sensor communication in Domoticz, can anyone translate the arduino serial log for me?
    0;0;3;0;14;Gateway startup complete.
    0;0;3;0;9;read: 255-255-0 s=255,c=3,t=3,pt=0,l=0:
    255;255;3;0;3;
    0;0;3;0;9;read: 255-255-0 s=255,c=3,t=3,pt=0,l=0:
    255;255;3;0;3;
    0;0;3;0;9;read: 255-255-0 s=255,c=3,t=3,pt=0,l=0:
    255;255;3;0;3;

    I think it is communicating but will not show up in Domoticz??

    Cheers


  • Admin


  • Hero Member

    @kopite Your sensor-node is trying to get a Node-id from the controller.
    The 0;0;.... messages come from the controller
    The 255;255; message come from you node and are "internal" (3) messages with "node_req" from the node. Domoticz should issue a node-id when received, but supposedly this is not happening.



  • Make sure that you have 'accept new devices' in Domoticz's settings enabled.



  • Tried this now with a few sensors and gateways and still get the same result in the serial monitor.....im thinking it is the radio now? possible need a capacitor?


  • Hero Member

    @kopite As others have posted above, it looks like the gateway is receiving the packets from the sensor and the controller (Domoticz) should act on them and issue a node-id to the new node. Domoticz does not appear to be providing that, so it looks like a communications or configuration issue between Domoticz and the gateway, not a radio issue.

    Cheers
    Al



  • @Sparkman , the log is from the serial monitor on arduino IDE?



  • Your log seems correct. I think your problem comes from Domoticz. Have you declared new arduino gateway in Domoticz? If so, can you show us domoticz's log?



  • All I get from Domoticz is
    2015-05-15 17:24:33.161 MySensors: Using serial port: COM5
    2015-05-15 17:24:34.657 MySensors: Gateway Ready...
    2015-05-15 17:24:45.881 New sensors allowed for 5 minutes...



  • @kopite have you tried most simple sensors?
    It should work. What version of Domoticz do you use? Latest beta?



  • im using the latest Beta V2.2439, ive tried Relay, Humidity and Pulse counter



  • What are logs on Domoticz when you restart your node?


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.