Can not reply on the forum or Locked

  • Hero Member

    I tried to post something on the forum from my Linux machine using Firefox or Konqueror but that is not working out.

    • In Firefox 30 I can type a reply and press submit but nothing happens and no reply is added. Same problem trying Firefox and WinXP.
    • In Konqueror I see an orange line above all threads saying "This thread has been deleted. Only users with thread management privileges can see it." is displayed but I can still see the thread although every items is Locked (Blue box)

    Eventually installed Chromium and that works but ... I am the only one having problem access the forum using Firefox?

  • Mod

    When you see this reply it means I was able to submit it (Firefox on Mac though and used only for this test).

  • Hero Member

    Still using Chromium I enable "Live HTTP header" while trying using Firefox and I see:
    GET / HTTP/1.1
    User-Agent: Mozilla/5.0 (X11; Linux i686; rv:30.0) Gecko/20100101 Firefox/30.0
    Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
    Accept-Language: en-US,en;q=0.5
    Accept-Encoding: gzip, deflate
    Cookie: express.sid=s%3AomLCnc8o2jWjEhxQxplyLt9HFWZwqLOR.5R8%2B4xVScOLLt2D9cAs2BVn%2Bspl3kIGOIop1Ie5sr1U; _ga=GA1.2.1667585123.1404853555
    Connection: keep-alive
    HTTP/1.1 502 Bad Gateway
    Server: nginx/1.4.1 (Ubuntu)
    Date: Sun, 20 Jul 2014 19:53:30 GMT
    Content-Type: text/html
    Content-Length: 181
    Connection: keep-alive

    I think this has to do with the problems but do not know what to conclude based on it.

  • Admin

    The forum is utilizing websockets. Is your webbroswer complient? If not it should fallback to plain ajax (or long pull dito).

  • Admin

    Hmm.. Searching around for similar issues I found:
    But the ngnix log does not show any "upstream sent too big header while...".

    Instead I see a lot of "upstream prematurely closed connection while reading response header from upstream" in the log. Which leads to believe it has something to do with:
    But this seem to be an issue in all browsers.

    I might try increasing ngnix cookie buffers anyway like suggesten in first link later. I'll contact you @daulagari again when it has been done.

  • Admin

    Buffers has been increased. Could you test with your firefox again?

  • Hero Member

    Tried once more with Firefox but same behavior as before:

    • I press Reply and the normal editor pops up in the bottom of the screen
    • Type the message left and the preview right looks fine
    • Press Submit and in the top of the screen a turning progress circle is displayed for five seconds and after that it changes into a V
    • But the editor window in the bottom remains open and no message posted

    Made a capture using Wireshark and see quite some 502 Bad Gateway coming by.

    See the site is running nginx and I am running that also on my Cubieboard2 and also had 502 Bad Gateway problems and solved them eventually, see

    The stackoverflow link is for a very old version of Firefox; I doubt if that is still relevant. I this article,, two year old 😉 maybe helpful?

  • Admin

    The forum is node.js based (not php). I doubt it's right related. The forum runs inside a dockers container with a ngnix proxy (which has websocket proxying enabled) in front of everything.

  • Hero Member

    Tried again with Firefox and now things are working.

    Problems solved!

Log in to reply

Suggested Topics

  • 1
  • 4
  • 2
  • 9
  • 274
  • 3