💬 Easy/Newbie PCB for MySensors



  • @sundberg84 I hit this post again today with the intention of finally biting the bullet and buying some boards - but then I saw your notes about the next revision of the board. Could you tell me when you're expecting to release that? Is it worth me waiting a while?

    Thanks!


  • Hardware Contributor

    @velkrosmaak - I dont know - im in the middle of another project and it wont be any bigger changes.
    See the changelog above.
    Only thing that can matter if you planning to do a project with 2 interupts that need D2 and D3,



  • @dbemowsk said:

    @Lior Rubin, you said "ESP8266 option rather than Arduino " did you mean "ESP8266 option rather than nRF24"? Also,why would you need to put an TX/RX or FTDI connector. IF you use pro mini , it has the FTDI connector on it already.

    I meant to use the ESP8266 option rather than the pro mini+nrf24. So to transfer the sensors to use IP and not radio.

    for the FTDI, the connection on top of the arduino board is hard to connect because of the terminals.



  • @Lior-Rubin said:

    I meant to use the ESP8266 option rather than the pro mini+nrf24. So to transfer the sensors to use IP and not radio.

    for the FTDI, the connection on top of the arduino board is hard to connect because of the terminals.

    As for the FTDI connector, you have a few options. You can switch the right angled header pins for straight ones and plug in vertically. Option 2 is to mount it reversed pointing away from the terminals. Option 3, which is what I do, is to mount the Pro Mini with female header strips on the board. The ones that I use bring it up high enough where the FTDI connector clears the terminals if I use them. Doing it that way gives you the added benefit of being able to remove the pro mini and swap it if there is a problem.


  • Hardware Contributor

    @sundberg84 said:

    Only thing that can matter if you planning to do a project with 2 interupts that need D2 and D3,

    Even for that the current version is not a big problem. Just cut or unsolder the interrupt pin on the NRF24.



  • Hi
    Do anyone have a working sketch for a 2xAA battery powered DHT22 with Mysensors 2.0 that works with this pcb rev.8 ?

    //PT


  • Hardware Contributor

    @pettib - almost 😉 https://github.com/sundberg84/MySensors2.0.0/blob/master/UVSensor/UVSensor.ino
    This is a UV sensor - so everything else works. Just exchange the UV code for DHT22 code.



  • Thanks. I will try this.

    //PT



  • Hi guys!

    Any suggestions as to why my voltage on 3.3 is either battery voltage (if BAT is short circuited) or 0v if BAT not short circuited. I have the same problem on two boards so I guess I´ve done the same mistake twice and that it´s not H/W error.. This means the radio doesn´t work unless I have brand new batteries or hook it up to USB for programming..

    0_1480076010564_20161124_204635.jpg



  • @ChrisW, I am assuming you are using 3.3v nanos. What are you using for batteries? Where are you measuring your 3.3v? I am assuming that you are measuring it on the radio on pin 2. When using the power booster at 3.3v, first measure the output power of the booster at the pin closest to the RAW input. If you have your 3.3v there, then you need to add a jumper to the regulator pads since you are not using a 3.3v regulator (below the 0.1uf and 10uf capacitors) for the radio. That jumper needs to go between the 2 pads near the flat edge of the regulator silkscreen. You can also jump the lower two pins from the BAT and REG jumpers, that does the same thing. This jumps your 3.3v over to the radio power in. DO NOT put a jumper across BAT. Adding that can ruin your radio if you put more than 3.3v on your PWR in from your batteries. The nRF24L01 radios are sensitive to the power applied to them.


  • Hardware Contributor

    @ChrisW - im sorry, Im dont really understand you - english isnt my first language, could be why.
    Could it be a short somewhere? and booster is mounted in the correct way? Please describe some more and answer the questions @dbemowsk asked and im sure we can figure it out.



  • @dbemowsk , yes I am using the 3.3 nano.
    I´m using 2 regular AA batteries 1,5 V. I am measuring on VCC for radio, which should be boosted to 3.3V.
    VCC on the left pin layout is 3.3, the 3.3-pin is same as battery.

    Booster output is 3.3V.
    I was unaware of the need for voltage regulator to the radio - since I´m going with 3.3 all the way I never realized this. That´s probably the culprit right there.

    I´ll try your suggestion tomorrow and see if it works out. Thank you for your time.

    @sundberg84 , det är OK, det är inte mitt förstaspråk heller.. 😉
    Tack för ett bra nybörjarpaket - väldigt enkelt att få ihop en bra hobbysensor!
    Jag misstänker att det är som dbemowsk säger - att jag skulle haft en booster till radion också.


  • Hardware Contributor

    @ChrisW - Hi! (Writing in english so all can understand, även om det inte behövs 🙂 )

    When you are using 3.3v pro mini and booster with BAT jumper it should not be 3.3v over the radio. This is because the booster generates alot of noice and the radio can handle down to 1.9v without any issues. This is how the PCB was designed due to learning by doing. The radio uses what comes raw from the batteries without booster. Evreything else on the PCB is boosted.

    If you are using 2xAA you should be able to run the it beteen 1.9V and 3V (which is most of the batteries since the voltage drops pretty fast below that).



  • @ChrisW said:

    I was unaware of the need for voltage regulator to the radio - since I´m going with 3.3 all the way I never realized this.

    That's what I was trying to explain. You do not need the regulator, but the board is set up to use one in the event that you might use a 5 volt nano. That is why I mentioned adding the jumper wire. That is to jumper the input and output pins of where the regulator would normally go IF you were using a 5 volt arduino.
    regulator jumper placement

    EDIT:
    @sundberg84 I think we were typing messages at the same time. I did not realize that the radio could run at that low of a voltage. My method jumps the boosted 3.3 volts over to the radio. Shouldn't adding the 0.1uf and 10uf caps attenuate the noise from the booster when jumping the regulator pins?


  • Hardware Contributor

    @dbemowsk - What I know the booster generates ALOT of noice and are really dependent of the quality of the booster. They are expensive as it is and if you buy the china ones its a big risk you get disturbance to the radio even if you use caps!

    I would not recommend to jump the boosted voltage to the radio. It might work in some cases (depending on the hardware) but there is a risk doing it.

    Some boosters even generate so much noice that even if you havent it connected directly to the radio it doesnt work.



  • Hiya Sundberg
    I think Im having boost converter noise issues from a dodgy ebay batch.
    I have soldered up 11 of your boards to date and two are real flaky.
    Aside from swapping out the boost converter is there a way to reduce the noise? 0.1UF cap across the radio power/gnd pins? Or across the GND and output pins of the booster itself?
    They are kind of expensive so dont want to bin them if I can bodge up a fix...
    Thanks,
    Matt


  • Hardware Contributor

    @Matt - Hi!
    This issues has been addressed in the thread before, see if you can find it.
    I have had luck with a 0,1 ceramic cap on the booster from out to GND. There is more advances methods to reduce noice which I haven't tried but you can read about them above in the thread somewhere. As you said they are a bit pricey but some boards have I just not been able to fix due to really bad booster and scrapped.



  • @sundberg84 Hiya yep found it, starts with your post 30th June 2016.
    To be honest its a bit over my head, inductors. ferrite beads etc. A picture of what to solder where would help.
    I did try to 0.1uf cap across OUT and GND but the things still only work for a minute then go silent.
    I will desolder existing booster then add a jumper from vin to vout to see how stable they are with a good solid battery supply.
    If they are reliable I will order some more boosters, but it seems a bit hit and miss as to reliability...
    Unless someone can post a pic or explain (for dummies) how to filter the booster effectively?
    I should pull out my scope, which involves tidying my workbench, not a task I undertake lightly....

    Thanks,
    Matt



  • Have been doing some investigation of the boost converters, just with my DMM, which doesnt have frequency function.
    However it can measure ac ripple. On the working boosters there is a ripple amplitude of around 0.02V. On the flaky ones its anything from 0.03 to 0.05V. So this makes it easy for me to test to converters before comitting them with solder.



  • @alexsh1 I know its a bit historical but could you post a pic or explain how you connect the lc-filter to the boost converter? Having issues here, 0.1uf cap didnt help...
    Thanks....


  • Hardware Contributor

    @Matt - It was some time ago now i experienced with this... but something like this:
    0_1480492998281_1.JPG and to be hones maybe it was from ground (middle pin) to vin (left pin)... try both, cant do any harm. As I said - in most cases it works... I buy 10 and 10 batches and around 7-8 works good enough.



  • @sundberg84 thanks, that is how I have soldered the 0.1uF cap but it hasnt improved things.
    I was hoping @alexsh1 would be happy to chip in here and show me how to solder the 220uf cap and 3.3uH choke?


  • Hero Member

    @Matt Take a look at link text



  • @AWI hey thanks! I especially like this
    0_1480738566004_lc-filter-circuit1-300x281.jpg

    Although.... Something tells me L should be in series on Vout, sureley if it was between BAT and 3.3 voltage weird things would happen....
    Might be time to finally try to figure out how to use that cheap old scope in my garage...
    Also, as it happens, am just getting in to RC stuff (well for my son, but you know...)


  • Hardware Contributor

    I have now updated this to Revision 9!

    • Bigger mounting holes 2.5mm
    • IRQ Jumper from Radio. This makes this trace disabled and D2 can be used for interupts unless jumper is connected.
    • BAT and REG jumpers changed positions for better tracing.
    • MysX 2,6
    • Text on voltage regulater (Vout/Vin/Gnd)
    • Bug with G on CAP now on the right side.
    • GND and VCC swapped - so you could use a 2 pin block for GND/RAW as well.
    • Capacitor to filter the booster output more (optional)

    Please wait for PCB house to update to new gerber files before ordering (It should say M.Rev 5 (Manufacturer rev 5) for lastest revision when selecting PCB house)
    I have not yet tested this rev... but no major changes so it should be pretty safe.
    If you want to be 100% sure, download and order Rev 8.



  • @sundberg84

    Been a while since I made sensors now - but so what.. ordered 10 pcs in order to try it out 🙂



  • @sundberg84 said:

    • Bug with G on CAP now on the right side.
      Wait, what?
      Missed this. I am using v8 boards. Cant seem to figure out how to search individual threads and 247 posts is a bit much to go through tonight. Will get the DMM out and try to figure it out, but what cap is labelled wrong?

    Thanks,
    Matt


  • Hardware Contributor



  • @sundberg84 cheers, no problem on my boards, multimeter confirms this...



  • Hey I recently got a batch of ten pro 3.3v pro minis from ebay, I removed vreg + LED on two of them and they no longer work... Well, I cant upload. I have done this low power mod heaps of times, the boards are different from ones Ive seen before, has anyone here had this problem? Or am I just a problem magnet? Have yet to solder programming headers on a non modified board to see if its a bad batch... Maybe main power is routed through the vreg or LED regardless or something? I dont have the eyesight or mag abilities to play around...
    0_1482260686279_upload-22833514-2461-4622-9259-2d9e9fa6ed9b


  • Hardware Contributor

    @Matt - I have killed some when i tried to remove them led/reg with a knife (ie cutting). So i began desoldering them which workes nice. I have killed one because of a short circuit and one because i damaged the pad.

    Could be as you say another routing if its a new clone. Removing the led/resisotor led to being with should not affect this as it most likely only goes to ground.



  • @sundberg84
    Thanks for your reply. Given I've done six or seven to date without issue I am somewhat skeptical that I have borked two in a row. I use a fine tip hakko iron, solder sucker, wick + a tiny wee flathead screwdriver for the butchery.
    Maybe its time I invested in a magnifying glass heh.
    Is it necessary to remove the vreg as I would think its not doing anything anyway as we are powering via VCC rather than raw?


  • Hardware Contributor

    @Matt - Sounds strange. Magnifying glass is cheap and good 👍



  • @sundberg84
    Yeah it is a bit. As I said, may yet be a bad batch, too busy with other things right now to test a third one.
    Mind you, just found this and as I suspected, there appears to be no point in removing the regulator if we are powering directly via vcc.



  • @Matt said:

    Hey I recently got a batch of ten pro 3.3v pro minis from ebay, I removed vreg + LED on two of them and they no longer work... Well, I cant upload.

    Did you try to use side pins for Vcc/Gnd connections from usb-ttl adapter? It is known for some clones that Vcc/Gnd pins on programming header do not work after regulator and led are removed and side pins must be used for uploading sketch...



  • @ferro ooh hey, didn't know that... Will have a go. Thanks!



  • @Matt said:

    @ferro ooh hey, didn't know that... Will have a go. Thanks!

    Nup, didn't work. Must have killed them somehow by removing the regulator. Have a third one running just fine, minus the LED.... Oh well.



  • Had further problems with intermittent sends. Sometimes on initial presentation it only sends the sketch name and not version number. Also sends are infrequent up to six hours apart. When it does send it often only sends one child_id when there are three to send.
    Previously I thought this was most likely an issue with a noisy boost converter. However I just tried replacing the 4.7uf cap on the radio with a 47uf one. Problem solved!
    Matt


  • Hardware Contributor

    @Matt - Nice to hear problem solved! Its again the sensitive radio and the booster might be the cause since changing the cap worked.
    One trick is also to add a delay(10) between the presentations if possible. Sometimes the radio cant keep up or something...



  • Gah! I ordered through the https://www.openhardware.io/order/4/PCB10X link from Itead but got the rev8 boards. Thought the "I always update the gerber files for sale" meant it was safe to order...


  • Mod

    @Efflon did the order say version m5 when you ordered? Which date did you place the order?



  • @mfalkvidd I ordered January 2 and can't remember what version was stated. I'm quite sure I picked Itead because it had a higher version numer (and a slightly higher price), honestly don't remember. All I know is that I didn't read this thread but rather just browsed through the page and clicked order. Afterwards I realized it wasn't clear if it was the 5V or 3.3V version but the order said 5x5cm. I also missed to choose color but "grönt är skönt".
    Guess what confused me most was the statement "It may say another rev. at the orderpage but this is not EasyPCB rev but the rev for manufacturer." causing me to be trigger happy 😄


  • Hardware Contributor

    @Efflon - sorry to hear you got rev 8 if you wanted rev 9.
    I wrote this notice just because itead was so slow updating to the right revision! I also spoke to hek about this a month ago according to my chat log.


  • Admin

    Sorry to hear... Checked the log. The order was for manufacturer revision 4 (which is what @sundberg84 call rev 8 ).

    The system automatically increments the revision number each time an author makes a new release. Each manufacturer must set price on each revision(which in some cases may take a while if they do this manually). Until they've done that, any older revision where they've set a price is still available for purchase.

    The revision is stated below the big order-button.



  • 0_1485115385923_IMG_1116.JPG
    Could anyone explain me, why position (polarity) of condensers 4.7uF on REV 8(blue) and REV 9 (red) are different?



  • @Amput said in 💬 Easy/Newbie PCB for MySensors:

    Could anyone explain me, why position (polarity) of condensers 4.7uF on REV 8(blue) and REV 9 (red) are different?

    It's a bug in v8 fixed in v9, so v9 is correct, see link this post



  • @SUNDBERG84 - Do you have a board/design for the RFM69 radio ?

    Rergards,
    Martin



  • @martins - you can use NRF2RFM69 if you want to use RFM69 with Newbie PCB board. I'm using it too, works fine with 3.3V arduino. For 5V arduino you will need to add level logic converter too.



  • @ferro
    Pity because that would double the cost of the sensor board:

    Order PCBs for Easy/Newbie PCB for MySensors : $15
    Order PCBs for NRF2RFM69 : $15

    Thanks,
    Martin



  • @ferro said in 💬 Easy/Newbie PCB for MySensors:

    @Amput said in 💬 Easy/Newbie PCB for MySensors:

    Could anyone explain me, why position (polarity) of condensers 4.7uF on REV 8(blue) and REV 9 (red) are different?

    It's a bug in v8 fixed in v9, so v9 is correct, see link this post

    Thx for answer :-).


  • Hardware Contributor

    @martins - No, not at the moment. It has been asked before but I have never got my head around it.
    As i told before, you are happy to develop it yourself. I have some other things in my list but in the future maybe 🙂



  • This post is deleted!


  • This post is deleted!


  • Hi
    I've tried to order the capaciter and voltage regulator from our local electronics supplier. The choice is too big. Could anyone please help a "newbie" to select the right parts for a raw powered 5V version

    • 4.7uF capacitor
    • voltage regulator
    • 0.1 and 10uF cap
      http://www.distrelec.ch/ can't select the parts because of missing size and especially for the voltage regulator the exact type.

  • Hardware Contributor

    @N00phi - I usually just select the ones at www.mysensors.org/store but if you have a specific site you wish to order from I can choose for you.



  • @sundberg84 It would be absolutely great if you could do so! I would order at http://www.distrelec.ch ...


  • Hardware Contributor

    @N00phi for the capacitors: http://www.distrelec.ch/search?q=electrolytic+capacitor&filter_Rated+voltage~~VDC=50&filter_Diameter+housing~~mm=4&filter_Diameter+housing~~mm=5 (choose the axial types which is the one with two legs).

    As for the voltage regulator I use LE33ACZ 5V-3.3V which i cant find on that site.



  • @sundberg84 said in 💬 Easy/Newbie PCB for MySensors:

    choose the axial types which is the one with two legs

    Just for clarification, there is axial lead and radial lead components. The axial leads have both wires coming out of one side (as @sundberg84 mentions it looks like two legs). Radial leads have one wire coming out each side. I almost never use radial lead capacitors.



  • @sundberg84 Thank you! One more question.. on the photo, there is a flat broun capacitor, what are the specifications for that one? Is it 0,1uF? But thats not an aluminium electrolytic capacitor, is it?
    Oh, and the voltage regulator is available on aliexpress, found that one.


  • Hardware Contributor

    @N00phi said in 💬 Easy/Newbie PCB for MySensors:

    @sundberg84 Thank you! One more question.. on the photo, there is a flat broun capacitor, what are the specifications for that one? Is it 0,1uF? But thats not an aluminium electrolytic capacitor, is it?
    Oh, and the voltage regulator is available on aliexpress, found that one.

    Yes it's the 0.1uF capacitor. It's a ceramic disc capacitor, but you won't have to search for the type of capacitor on aliexpress, low value capacitors are most of the time (always ?) ceramic disks if they are not of SMD type.



  • I would like to use this PCB with a 3.3V I2C sensor (data line and power must be <3.6V) and AC power. Is there a recommended way to accomplish this?


  • Hardware Contributor

    @cmrockwell - Sorry, Im not following...
    AC Power? You need some AC-DC converter then and this is not the intend of the PCB, sorry.



  • @sundberg84
    Sorry, I wasn't clear. I just meant running from a DC power supply, not batteries. It seems that the intended use is to have 5V Vcc when running from a power supply, but I would like a 3.3V Vcc. Thanks for your help. I have 10 of these PCBs in hand.


  • Hardware Contributor

    @cmrockwell You can use a 3.3V / 8MHz pro-mini board and power everything with 3.3V.


  • Hardware Contributor

    @cmrockwell - yes, the pcb is designed like @cmrockwell said. You can use either 3.3v or below (batteries) or a 5v regulated voltage. If you choose the 3.3v/bat version you need a 3.3v pro mini.



  • @sundberg84
    OK, I figured out how to do what I wanted. I am planning to connect a regulated power supply that provides ~3.3VDC. The main thing I had to figure out was how to configure the PCB when neither a battery booster nor a regulator are needed. I think either shorting the REG pin and shorting the regulator or shorting the BAT pin and shorting the battery booster would each achieve the desired result.


  • Hardware Contributor

    @cmrockwell - well done!
    Yes, digging deeper into it you can probably hack it many ways with jumpers and wires.


  • Mod

    If I want to use a mini pro 3.3v and a 18650 battery that I have lying around, should I use something like THIS or do you think there is a better/more efficient way?


  • Hardware Contributor

    @gohan - im not that good in efficiency in boosters and converting voltage. Im sure that would work! The main thing is 1) deliver correct voltage and 2) if they are to noicy they will interfere with the radio and make the communication fail.



  • I having trouble to order this board from DirtyPCB.
    Both the link in the beginning of this thread (Rev8) and the link in the OpenHarware page just directs me to an empty DirtyPCB order page, with no board preloaded. It wants me to upload files.
    Does anyone know how to order from DirtyPcb without uploading the boardfiles?


  • Hardware Contributor

    @popunonkok - the link to DirtyPCB is not posted or maintained by me. If you want the latest revisions please go to order under openhardware.io = https://www.openhardware.io/order/4/PCB10X. DirtyPCB is not an option there so if you want to use them you need to download the gerberfiles for the project = https://www.openhardware.io/view/4/EasyNewbie-PCB-for-MySensors#tabs-design and upload them according to their instructions = http://dirtypcbs.com/store/pcbs/about (see order)



  • Iv just orderd Rev8.

    I have a primary question, might have a couple more later on.
    In the info about the board it says:

    "BAT: Short this if you are using batteries as power supply. It will activate booster circuit and feed the radio directly from the batteries and not voltage regulator"

    It says about the same on the image of the board.

    My question is. Why would I want to powewr the radio directly from battery and not from the Booster? Wouldent that make the radio not to function like it sould when the voltage dropps?


  • Hardware Contributor

    @popunonkok - if you search the forum and this thread about noice in the boosters you will find a big search result. The boosters is, to be honest, pretty bad. They generate alot of noice which interfere with the radio which is pretty sensitive. By "learning by doing" we have figured out that if you are using a booster the best way is to provice power to the radio directly from the batteries to avoid the noice... the radio will pretty much fail if you dont.

    The radio can handle down to 1.9 v so this will be your minimum voltage for the circiut.



  • Hmmm... Ok...

    I had only read that the boosters helpt to drain the battery completely, had missed that they "messed" with the radio.

    It will be really interesting to see what kind of battery life I can get out of 2 or 4 AA batteries on different types of nodes.

    When I look at the Specs for the Pro Mini board the supply voltage is 3.35 - 12v.
    I guess that means that without a Booster 2 AA batteries wont be able to run the Pro mini for a long time at all.


  • Hardware Contributor

    @popunonkok - you are correct, they are good for they "suck all the juice" out of the batteries. Without modifications the Pro Mini 3.3v have a lowerst voltage of 2.8V (called Brown out detection) Because of that when you use 2xAA you need the booster to keep a stable 3.3v and most of the booster can convert everyhing down to 0.9v back to 3.3v. The radio can handle down to 1.9v and that will be your lowerst point.

    I have nodes reading temp and humidity with a dht22 every 15min, running this setup and they last around 1 year each.
    You need to search the forum and https://www.mysensors.org/build/battery for power saving with battery. The most common first step is to remove the voltage regulator and the led. Then you sleep the node when it isnt active.

    On this image you see the led removed (red arrow). I think its easier to remove the resistor (black circle, marked 102) but its the same result. Voltage regulater (red circle) is removed as well. Note that many sites say cut the trace but its much easier to desolder them.

    0_1488381852786_1.JPG

    Using the internal voltage regulator (3.35 - 12v) will kill the node in weeks/days if you run them on 2-4xAA because of the high current drain. My aim building a newbie/easy PCB is a sleepcurrent of 0,1mA or 100uA.



  • hi there,

    Thanks for the easypcb! I'm trying to build a small solar powered weather station (like these: https://forum.mysensors.org/topic/841/solar-powered-mini-weather-station), but just found that the battery that came with the solar panel only provides 1.2v. The booster works ok and I can power the arduino, but it's no enough for the radio :-(. Since powering the radio from the booster is not a option, I'm at a dead end. Or there's a way to still using this battery/solar panel?


  • Hardware Contributor

    @chrlyra - you need 1.9V minimum for the radio. There are more advanced boosters you could try which probably is better and less noice... but this PCB was not designed for that purpose so sorry, I cant help you.


  • Mod

    @chrlyra
    There is another project called solar harvester that uses a supercap to store energy



  • So a question I have always wondered about the voltage regulator is do you really need to desolder it if you connect your incoming power to the 3.3v pin and not the RAW pin? I would have thought the regulator would only drain power if it was converting the RAW power down to 3.3v.


  • Hardware Contributor

    @dbemowsk - your logic sounds right, but i think it will draw power anyway... only way to figure out is to measure or google 🙂



  • I managed to change my PCB order, I saw that one of the updates to rev9 was the ability to use Pin 2 as GPIO instead of going to the Radio where it is unused. So now I have a order for Rev9 instead.

    I will try to desolder the led or resistor and the voltageregulator.

    Thanks for sharing your design.


  • Hardware Contributor

    @popunonkok Good luck - let me know if there is any other questions.


  • Hardware Contributor

    @dbemowsk in fact current is leaking through the regulator when its input is floating, you can check the "reverse leakage current" value on the data sheet of the linear regulator used on your promini boards then decide if you can accept it or not, depending on your circuit.



  • Hi -

    I wanted to know if this config is OK:

    Attach a LIPO battery to PWR and GND.
    Cut off the right side of the board.
    Use a 3.3V pro mini.
    Add a regulator (like a MCP1700) and necessary caps. (Spec says 1uF).

    The idea is that the board and sensors get 3.2V - 4.1 V (which should be OK).
    The radio gets 3.3V.

    Thanks!


  • Hardware Contributor

    @ileneken3 - sounds right, you should short the jumper REG which will feed everything the LIPO voltage. If this is higher than 3.3v I dont know what will happen but adding the voltage regulator for the radio will make sure that one is ok. I dont know about the pro mini, it it can handle up to 4.1v but I guess you will find out.


  • Mod

    I'm curious too if will handle the 4 volts or not😀


  • Hardware Contributor

    No problem with the promini. Limit is from atmega and it's 5.5V I think (at least 5V anyway 🙂 )
    You will just have HIGH level voltage at battery voltage at the outputs instead of 3.3V


  • Mod

    So technically you can power a 3.3V pro mini with a LiPo battery, you only need a regulator for radio, correct? Can you still make reliable battery voltage measurement? I Have a NRF24 adapter with a AMS1117 onboard, will that still work or does it need 5v?


  • Hardware Contributor

    @gohan said in 💬 Easy/Newbie PCB for MySensors:

    So technically you can power a 3.3V pro mini with a LiPo battery, you only need a regulator for radio, correct?

    Correct.

    Can you still make reliable battery voltage measurement?

    Yes, check here :
    https://forum.mysensors.org/topic/186/new-library-to-read-arduino-vcc-supply-level-without-resistors-for-battery-powered-sensor-nodes-that-do-not-use-a-voltage-regulator-but-connect-directly-to-the-batteries

    I Have a NRF24 adapter with a AMS1117 onboard, will that still work or does it need 5v?

    From the datasheet typical dropout voltage is 1.1V and it can be up to 1.3V.
    So to get 3.3V at the output you need at least 3.3 + 1.1 = 4.4V. It won't work with your battery, you need to use another voltage regulator with a much lower dropout voltage.



  • @Nca78

    At least according to the specs, mcp1700 will do the trick (both in terms of drop out voltage and low power consumption for battery usage). I will try it.


  • Mod



  • @ileneken3

    Regarding the MCP1700 as a regulator (I ordered these: https://www.aliexpress.com/item/5-pcs-MCP1700-3302E-TO-MCP1700-Fixed-LDO-Voltage-Regulator/32781100568.html)

    first connected the LIPO->TP4056->MCP1700 to the GND and PWR of the board. (I made a homemade little regulator board). From all appearances, it works great, and I end up with a nice compact sensor/battery. But I want to make use of the Easy/Newbie board. I tried hooking it up to the 3 pins marked regulator, but it didn't seem to do anything. Am I missing something? The orientation can be confusing, but I think I got it right. I measured 4.1 volts to the radio, which will fry it.

    Thanks!


  • Hardware Contributor

    @ileneken3 - the board is created for Le33a voltage regulator which has a different pinout than yours.
    You have to adjust to that and not just put it in according to the pcb.

    0_1488958021451_1.jpg



  • @sundberg84
    I did adjust to the different pinout. I checked it multiple times, checked soldering - it always seems like the regulator is not regulating anything - the radio always gets 4.1 volts from the LIPO.
    From looking at the specs, the LE33 is pretty close - with the biggest difference that the MCP1700 can handle more current.
    Maybe I should just get the LE33 ones.

    Oh well...


  • Hardware Contributor

    @ileneken3 your problem with le33 will be the quiescent current which is high, datasheet says "typ. 50 μA in OFF
    mode, 0.5 mA in ON mode, no load". 0.5mA will not give you a good battery life...
    Compared to a typical value of 1.6µA on the MCP1700 (max at 4µA), you should stick to it if you are using a battery.

    Did you test the MCP1700 on a breadboard ?



  • @ileneken3 Can you post a pic showing how you have this wired? preferably the side where your battery is connected. I would like to see where you have your battery connected and how you have the board wired.



  • @Nca78

    Yes, I agree. I didn't look closely enough at the currents for le33. The general rule of thumb seems to be:

    Current in "milli"amps -> only days or weeks for a battery
    Current in "micro"amps -> months on a battery

    So MCP1700 seems to be right for a LIPO here.
    I did test it on a breadboard. And then I built a little regulator board. It works great.. and I used a battery from an old cell phone that stills seems to work well.

    0_1489094016449_IMG_0927.JPG



  • @dbemowsk

    There's not much to the wiring (maybe that's my problem?).

    0_1489094182737_IMG_0928.JPG

    0_1489094210873_IMG_0929.JPG

    To attach the legs to be like a LE33, I swung the Vout of the MCP1700 all the way to the left.

    With a multimeter, I see 4.1 volts at the radio, and everywhere else.

    Thanks!



  • @ileneken3 OK, I think I see the issue. I think you need a jumper across the reg pads just to the right of the regulator. If you check with a volt meter between the regulator's V-In and the bottom reg pad, you should get continuity. Then if you check from the top reg pad to the positive lead of your battery, you should get continuity there also. you need to bridge that gap to get the power from your battery to the regulator.

    You would also be wise to add the 0.1uf ceramic and 10uf electrolytic capacitors just above the regulator. The 0.1uf will filter the power coming in to the regulator, and the 10uf will filter the output of the regulator. The other capacitor not to forget is the 4.7uf electrolytic just below the nRF24 radio. If you forget that, you will surely have radio problems.


  • Hero Member

    @ileneken3 like @dbemowsk says you need capacitors (and probably a jumper) . The LDO will go into oscillation without capacitors.


 

260
Online

8.3k
Users

9.2k
Topics

97.3k
Posts