controlling Teufel Sound System



  • Hi there,

    i am reading now for some time in this forum and it really helped me out a few times, thanks for that!
    But now i would like to actively participate here.

    The Problem:
    I have a Teufel Concept E in my livingroom. This can only be controlled with a special remote control.
    Because it is not automatically activating itself when there is an incomming signal (e.g. from my tv) i always need to search for the remote control.
    At the moment i can already switch a 433MHz Socket with an Arduino/Transceiver and Openhab to turn on my tv, it would be great if i could also switch the sound system with an Arduino. So i asked myself on which technology/frequency the remote control is sending and opened it up

    0_1497541564069_20170615_171132.jpg

    there was a leaking battery :persevere: but i don't mind because it's still working :)
    now im not really sure if that what i want to do is going to work. I think the black chip on the right side is the transmitter? I searched google for "N51822" and found a "NRF51822 bluetooth low energy" which can send on bluetooth low energy and 2.4GHz ultra low power.
    Do you think it is going to work? And what do i have to do to achive just a simple on/off remote with an arduino?

    Thank you very much for every answer on this!
    Ron


  • Hardware Contributor

    I guess the easiest way would be to connect a wire to the button on your remote control and directly control that instead of tinkering with the internals of the control ;)
    PS Also have you considered just sending Teufel an email and asking them what technology their remote is using?



  • thanks for that suggestion.
    I would like to not take the remote apart forever. Instead it would be nice to have an alternative to that remote

    I will write an Email to Teufel but i have a feeling that they won't tell me how their remote control works since they are selling them sepperately on their homepage. But it is worth a try :)


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.