Can't get ESP8266 gateway to work anymore



  • Hello,
    I have been using MySensors for a long time. First with serial gateway now with ESP8266 gateway. For months everything worked fine except for small dropouts. Due to dropouts I wanted to switch to current development branch, since then I can not get the gateway to work.
    The ESP delivers only the following output:

     ets Jan  8 2013,rst cause:2, boot mode:(3,6)
    
    load 0x4010f000, len 3460, room 16 
    tail 4
    chksum 0xcc
    load 0x3fff20b8, len 40, room 4 
    tail 4
    chksum 0xc9
    csum 0xc9
    v00051da0
    ~ld
    
    

    I use ESP07 with RFM69 and Standard Sketch. Compiled the code with Arduino IDE as well as with VS code, always with the same result.
    I disconnected RFM69 and checked the supply voltage. Have even used other calculator.
    Have also tested ESP12e.
    Erase Flash I have also already done.
    However, when I run other code on the ESP, it runs without problems.
    Erase Flash I have also already done.
    I just don't understand it.

    #define MY_DEBUG
    #define MY_BAUD_RATE 115200
    #define MY_RADIO_RFM69
    #define MY_IS_RFM69HW
    
    #define MY_GATEWAY_ESP8266
    
    #define MY_WIFI_SSID "my ssid"
    #define MY_WIFI_PASSWORD "my pw"
    
    #define MY_HOSTNAME "MySensors-GW"
    #define MY_PORT 5003
    #define MY_GATEWAY_MAX_CLIENTS 3
    #define MY_INCLUSION_MODE_FEATURE
    
    // Enable Inclusion mode button on gateway
    #define MY_INCLUSION_BUTTON_FEATURE
    // Set inclusion mode duration (in seconds)
    #define MY_INCLUSION_MODE_DURATION 60
    // Digital pin used for inclusion mode button
    #define MY_INCLUSION_MODE_BUTTON_PIN  3
    
    #include <MySensors.h>
    
    void setup()
    {
    }
    
    void presentation()
    {
    }
    
    void loop()
    {
    }
    


  • @Zwer2k , what do you mean by the 'current development branch'?
    The production version 2.3.2? or the latest code from the dev branch?

    If you revert back to your original version of the code, your gateway is working again?



  • Thank you fot the answer.
    I found out that the error was due to too new version of espressif8266. I had version 3.1.0 installed, but MySensors seems to work only with versions < 3.0.0. Otherwise the error comes up. Unfortunately I did not find any hint about this anywhere.


  • Mod

    @Zwer2k supported version is mentioned in the release note: https://github.com/mysensors/MySensors/releases
    https://forum.mysensors.org/post/102763

    But you're not the only one who missed it:
    https://forum.mysensors.org/post/110592
    https://forum.mysensors.org/topic/11694/esp8266-gateway/
    https://forum.mysensors.org/topic/11692/gatawayesp8266-compile-error

    If you have any suggestions on how we can make the information available in a way that would make it accessible to you, please share.



  • @mfalkvidd @Zwer2k
    I also had sneaky symptoms today when I was about to upgrade my WP5100 gateway to and Wemos D1 mini MQTT gw. The problem was that I just changed PC and installed both platformio (which is my new #1 choice) but also Arduino and then gets the latest and greatest by default. Everything compiled and uploaded fine on 3.0.1 but then nothing happened. Complete silence even in before() if Mysensors.h was included and I haven't seen that before. Changing the include to Arduino.h worked fine. What led me on the right track was that I by chance did the same operation on my old PC (that still was using the older esp versions) and found it working. Or actually it probably led me on another wild goose chase for a while...

    Works! (I know the release note says ESP8266: Update to 2.6.1)

    • framework-arduinoespressif8266 3.20704.0 (2.7.4)

    Unresponsive ESP after upload/boot!

    • framework-arduinoespressif8266 3.30001.210627 (3.0.1)

    Not sure if the runtime mismatch could be flagged in some way. I for sure spent a few hours on this even if I have hundreds of MySensors hours and nodes in me so I expect others will too. I actually saw the posts about compilation errors, but didn't make the connection and it was now first when I found the issue and was going to share my experiences I stumbled on your post 🙂

    It's hard enough to maintain a project like MySensors even without the world changing around you (new lib / frameworks versions) and even if it might be possible to add to version mismatch error/warning somewhere it's probably better to try ad inspire the esp library to fix what is broken. Now when I know I'm not alone about the problem it's more motivating to find out why it behaved like this 😉



  • My problem was that the compiler did not give any errors. The code could be compiled and imported without any problems, only when booting did the aforementioned error message appear. The error message was not an error message, but the normal boot output, which is normally not visible, because a different baud rate is usually set (boot outputs occur with 74880 baud). All indications for the error were "problems with the voltage". The power supply had worked before, so why should it suddenly not work anymore? I checked the supply anyway and even soldered on another ESP as a test, but of course it didn't help. In the process, I destroyed an ESP12e and an RFM69 by short-circuiting them.


  • Mod

    @Zwer2k mysensors replaces the arduino statup code, so you don't have to call setup and processing functions from your code.
    Likely something changed in the esp arduino 3.x implementation that causes the mysensors code to no longer work.
    If i can find some time I'll have a look.


  • Mod

    @Zwer2k my expectations seem correct. I created a bug report that also includes a rudimentary workaround.

    https://github.com/mysensors/MySensors/issues/1496#issue-968399284


Log in to reply
 

Suggested Topics

  • 7
  • 9
  • 7
  • 1
  • 1
  • 2
  • 5
  • 11

1
Online

10.3k
Users

10.7k
Topics

109.5k
Posts