[SOLVED] No communication between node and gateway - NRF24

  • Hi there,
    After few days trying to build a simple gateway-node system, and reading a lot of post about NRF24, I think it's time to ask you some help...

    My config

    • Arduino IDE 1.6.9 on Linux Mint
    • 2x CH340G USB to TTL
    • 2x Arduino Pro Mini 3.3V 8MHz
    • 2x Radio NRF24L01+ close to each-other
    • Powered by external 3.3V power supply with 47uF capacitor
    • Try with both stable (1.5.4) and development branch (2.0 beta from github) of mysensor librairies

    After sending SerialGateway & RelayActuator sketches from examples to arduinos, try to reboot for them to communicate.

    Whatever I did, always "find parent" without receiving any signal back...
    There is no "Check wire" nor "Radio init fail" message, and my config is working fine with "GettingSarted" sketch from TMRh20's RF24 libraries. By the way radio.printDetails() show "NRF24L01+".

    Does someone have a clue about what I'm doing wrong ?
    Thanks for help !

  • Hardware Contributor

    Hi @davy39 - I had the same issue last night - had the nodes to close to each other. Moved the other to anohter room and it worked fine.
    Also what controller do you use, and do you recieve ID for your nodes? A complete serial debug would help.

  • Are you using a controller? I had the problem with find parent a few days ago. If you are testing with only the gateway you need to manually give the nodes unique node id. In the sensor sketch, look for gw.begin in the setup function. You need to put the ID in as a parameter. I have


    to set the sensor value to 1. @mfalkvidd helped me out with this problem today. have a look at


    for the thread that I asked about node id in.

  • Thank you both for your answers.

    With so many parameters to play with, it was not easy to understand what was wrong.. But I think I finally got a way do get my hardware working πŸ™‚

    Here are my findings :

    • I thought I got RFM73 version of NRF24-like radios. They look like like here and here.
    • After checking and connecting all VCC and GND together, switch radios and arduinos... I got them suddenly working with Mysensors development librairies, then back to silence without apparent reason...
    • Indeed like @mark_venn suggested, I went back to stable librairies and try so set a static ID. Worked well... until it went back to silence again !
    • Then, following @mfalkvidd advice, I realised that flashing the eeprom_clear sketch solved my all my problems !

    My summary :

    • Ensure that your 3.3V power supply is strong enough.
    • Ensure that your arduino, radios and sensors are sharing the same GND and VCC.
    • Use development librairies from github
    • Flash eeprom_clear before flashing your mysensor sketches
    • Then gatewaySerial and relayActuator should be able to communicate "out of box", mean you'll monitor some lines like this on the gateway serial : 0;255;3;0;9;read: 0-0-0 s=255,c=3,t=15,pt=0,l=2,sg=0:

    Thanks again for your help, now I can start to play πŸ™‚

Suggested Topics

  • 10
  • 2
  • 6
  • 3
  • 15
  • 108
  • 14
  • 6