Mysensors Ethernet GW w5100 problem



  • Hi. I'm having a problem since i have upgrade to mysensors 2.0.0
    The problem it's this:

    2016-08-16 21:27:41.811 MySensors: connected to: 10.8.1.201:5003
    2016-08-16 21:27:42.811 MySensors: Connection reset!
    2016-08-16 21:27:42.811 TCP: Reconnecting in 30 seconds...
    2016-08-16 21:28:12.814 TCP: Reconnecting...
    2016-08-16 21:28:13.814 MySensors: connected to: 10.8.1.201:5003
    2016-08-16 21:28:17.815 MySensors: Connection reset!
    2016-08-16 21:28:17.815 TCP: Reconnecting in 30 seconds...

    And i can't pass from here don't now what to do.

    Can anyone give me a help on this?
    Thanks



  • I have had that with a serial gateway where is used a radio with external antenna.
    After switching to a normal radio the problems where gone.
    I had it connected to a RPI3 and it seemed to be a power issue as it was working fine connected to my laptop.



  • Hi.
    have change the switch the external radio antena for a normal radio but problem still continuos....
    I had domoticz runing on a RPI3 and just for debuging change it for a RPI2 but the problem still persists...
    I don't understand this error.

    With the mysensors 1.5 i had all runing OK on RPI3 with the same ethernet gateway.

    Other problem i'm having also no it's flashing the code into the arduinos all OK on the code but when i'm flashing it into the arduino gives a error at the end... and all this start hapening on this version 2.0.0.



  • I has the same issue with my Ethernet gateway.

    Which version of the arduino idea are you using?
    I found that both 1.6.9 and 1.6.10 would cause this issue. Uploading the code with 1.6.8 works perfectly.



  • arduino with mysensorv version 1.5.4 was the last one i had used and all was working OK.
    now i'm truing to use the mysensors 2.0.0 but hav this strange problem.
    I don't want to go back to version 1.5.4 and stay on the new version 2.0.0 but i want to still have the ethernet gateway because my gateway is located outside my house for better received all my sensors outside.

    Is there any fix for this problem? is this a bug?



  • There seems to be a problem with mysensors 2.0 and the arduino IDE version 1.6.9 and1.6.10.

    On the arduino website you can download old versions of the IDE. Try version 1.6.8.



  • Ok. problem with the arduino IDE fix, i can upload the code without errors thanks Jason37.
    But i still have the problem with the ethernet gateway no connecting to domoticz, same error, reconnecting.....



  • Can you show the sketch?
    I succesfully connected a ENC28J60 gateway and connected fine.



  • @tlpeter
    I'm using the sketch that can be found on the test folder from the library 2.0.0

    // Enable debug prints to serial monitor
    #define MY_DEBUG 
    
    // Enable and select radio type attached
    #define MY_RADIO_NRF24
    //#define MY_RADIO_RFM69
    
    // Enable gateway ethernet module type 
    #define MY_GATEWAY_W5100
    
    // W5100 Ethernet module SPI enable (optional if using a shield/module that manages SPI_EN signal)
    //#define MY_W5100_SPI_EN 4  
    
    // Enable Soft SPI for NRF radio (note different radio wiring is required)
    // The W5100 ethernet module seems to have a hard time co-operate with 
    // radio on the same spi bus.
    #if !defined(MY_W5100_SPI_EN) && !defined(ARDUINO_ARCH_SAMD)
      #define MY_SOFTSPI
      #define MY_SOFT_SPI_SCK_PIN 14
      #define MY_SOFT_SPI_MISO_PIN 16
      #define MY_SOFT_SPI_MOSI_PIN 15
    #endif  
    
    // When W5100 is connected we have to move CE/CSN pins for NRF radio
    #ifndef MY_RF24_CE_PIN 
      #define MY_RF24_CE_PIN 5
    #endif
    #ifndef MY_RF24_CS_PIN 
      #define MY_RF24_CS_PIN 6
    #endif
    
    // Enable to UDP          
    //#define MY_USE_UDP
    
    #define MY_IP_ADDRESS 10,8,1,201   // If this is disabled, DHCP is used to retrieve address
    // Renewal period if using DHCP
    //#define MY_IP_RENEWAL_INTERVAL 60000
    // The port to keep open on node server mode / or port to contact in client mode
    #define MY_PORT 5003      
    
    // Controller ip address. Enables client mode (default is "server" mode). 
    // Also enable this if MY_USE_UDP is used and you want sensor data sent somewhere. 
    //#define MY_CONTROLLER_IP_ADDRESS 192, 168, 178, 254   
     
    // The MAC address can be anything you want but should be unique on your network.
    // Newer boards have a MAC address printed on the underside of the PCB, which you can (optionally) use.
    // Note that most of the Ardunio examples use  "DEAD BEEF FEED" for the MAC address.
    #define MY_MAC_ADDRESS 0xDE, 0xAD, 0xBE, 0xEF, 0xFE, 0xED
    
    // Flash leds on rx/tx/err
    #define MY_LEDS_BLINKING_FEATURE
    // Set blinking period
    #define MY_DEFAULT_LED_BLINK_PERIOD 300
    
    // Enable inclusion mode
    #define MY_INCLUSION_MODE_FEATURE
    // Enable Inclusion mode button on gateway
    #define MY_INCLUSION_BUTTON_FEATURE
    // Set inclusion mode duration (in seconds)
    #define MY_INCLUSION_MODE_DURATION 60 
    // Digital pin used for inclusion mode button
    #define MY_INCLUSION_MODE_BUTTON_PIN  3 
    
    // Uncomment to override default HW configurations
    //#define MY_DEFAULT_ERR_LED_PIN 7  // Error led pin
    //#define MY_DEFAULT_RX_LED_PIN  8  // Receive led pin
    //#define MY_DEFAULT_TX_LED_PIN  9  // the PCB, on board LED
    
    #include <SPI.h>
    
    #if defined(MY_USE_UDP)
      #include <EthernetUdp.h>
    #endif
    #include <Ethernet.h>
    #include <MySensors.h>
    
    
    void setup()
    {
    }
    
    void loop() {
    }
    

    2016-08-18 11:45:08.681 MySensors: Can not connect to: 10.8.1.201:5003
    2016-08-18 11:45:08.681 TCP: Connection problem (Unable to connect to specified IP/Port)
    2016-08-18 11:45:08.681 TCP: Reconnecting in 30 seconds...
    2016-08-18 11:45:38.687 TCP: Reconnecting...



  • Can you ping it?



  • Yes i can, but i can see some lag on the ping today, on the last 2 days this was not happening....
    Pinging 10.8.1.201 with 32 bytes of data:
    Request timed out.
    Reply from 10.8.1.201: bytes=32 time<1ms TTL=128
    Request timed out.
    Reply from 10.8.1.201: bytes=32 time=1ms TTL=128
    Reply from 10.8.1.201: bytes=32 time<1ms TTL=128
    Request timed out.
    Request timed out.
    Request timed out.



  • Funny now the ping does not have any lag since i hade done a reeboot to the gateway



  • Can you still ping when it is disconnected? (IP conflict)
    Maybe power related?


  • Contest Winner

    @mrc-core The sketches under the test folder in the mysensors git (the library) is intended for CI evaluations. They are not examples to be used on target.



  • @tlpeter Have tryed no ip conflit thats ok

    arduino ide debug i get this
    0;255;3;0;9;TSP:MSG:READ 5-5-0 s=9,c=1,t=14,pt=2,l=2,sg=0:55
    0;255;3;0;9;Starting gateway (RNNGA-, 2.0.0)
    0;255;3;0;9;TSM:INIT
    0;255;3;0;9;TSM:RADIO:OK
    0;255;3;0;9;TSM:GW MODE
    0;255;3;0;9;TSM:READY
    IP: 10.8.1.201
    0;255;3;0;9;No registration required
    0;255;3;0;9;Init complete, id=0, parent=0, distance=0, registration=1
    0;255;3;0;9;TSP:MSG:READ 5-5-0 s=9,c=1,t=14,pt=2,l=2,sg=0:55
    0;255;3;0;9;TSP:MSG:READ 5-5-0 s=9,c=1,t=14,pt=2,l=2,sg=0:55
    0;255;3;0;9;TSP:MSG:READ 5-5-0 s=9,c=1,t=14,pt=2,l=2,sg=0:55
    0;255;3;0;9;TSP:MSG:READ 5-5-0 s=9,c=1,t=14,pt=2,l=2,sg=0:55
    0;255;3;0;9;TSP:MSG:READ 5-5-0 s=9,c=1,t=14,pt=2,l=2,sg=0:55
    0;255;3;0;9;TSP:MSG:READ 5-5-0 s=9,c=1,t=14,pt=2,l=2,sg=0:55
    0;255;3;0;9;TSP:MSG:READ 5-5-0 s=9,c=1,t=14,pt=2,l=2,sg=0:55



  • @Anticimex so i have to get my old code and remake it with the code from sensors 2.0.0


  • Contest Winner

    @mrc-core Examples have moved to a different repo: https://github.com/mysensors/MySensorsArduinoExamples



  • @Anticimex Thanks going to see yhe examples and tried to fix this problem.



  • I'm getting this error on IDE

    :\Users\marco\Documents\Arduino\libraries\MySensors/MySensors.h:233:5: error: #error UDP mode is not available for ENC28J60

    #error UDP mode is not available for ENC28J60

  • Mod

    @mrc-core I think the error is quite clear : you enabled UDP which is not supported in combination with ENC


Log in to reply
 

Looks like your connection to MySensors Forum was lost, please wait while we try to reconnect.