[SOLVED] Pressure Sensor Will Not Add to Vera

  • Whenever I try and add my pressure sensor to Vera, nothing seems to happen. I can add other sensors to vera without issue, but when I try and add the pressure sensor, Vera detects nothing.

    I have verified wiring with the BMP085 test program and I see pressure and temperature. When I run the PressureSensor.ino, upload it and then check serial output, I see nothing.

    Any suggestions?

    I am running on a Mini Pro (3.3v) with a serial gateway. Thanks.

  • Hero Member

    MySensor Version?

    If you have debugging turned on (it's on by default in 1.4) and you're not seeing anything in the serial, then I would think that you have a hardware problem (as long as you have the serial monitor setup correctly)

    Well I guess you could still have a software problem, but.....

    I would add some debugging code directly to the sketch and see if that shows up in the serial monitor.

    Can you easily swap out the Mini with a different one?

  • @ServiceXp I am on 1.4.

    I can try a different Mini, but I have verified that the pressure sensor works, by using the included test sketch. Does the pressure sensor sketch output anything to the serial when debugging is enabled? Sorry, I am a newbie when it comes to Arduino.

  • Hero Member

    I took a quick look at the sketch and it appears it does..

     Serial.print("Temperature = ");
     Serial.println(metric?" *C":" *F");
     Serial.print("Pressure = ");
     Serial.println(" Pa");

  • I solved the issue, it turns out you have to have debug disabled for the program to execute. I believe I saw someone else mention it in another thread and that is what lead me there. Thanks for the help!

  • Admin

    Could you perhaps try to introduce a few delays and see if that fixes the problem?

    Would be good if the sketch works without debug enabled.

Log in to reply

Suggested Topics