Using an UNO for Sensor With Negative Results



  • Hi, I've been having some really great success with the example sketches using the Nano's. I wanted to experiment with an Uno so I could use the dedicated DC adapter power input for a more permanent install. Trying to combine a light sensor and a motion sensor in one, but that's another thread.

    I'm simply not having any success getting the Uno to talk to my gateway at all. I've gone through all of the troubleshooting steps here, cleared my eeprom, triple checked and triple checked again my radio wiring, but I'm convinced it's in the radio that I"m having trouble.

    I stripped things down to just the Uno and the radio only and uploaded a known-good light sensor only sketch but don't have the light sensor plugged in(though I've tried that).

    I'm getting the following repeating:
    connecting at 115200
    send: 255-255-255-255 s=255,c=3,t=7,pt=0,l=0,st=fail:
    req node id
    send: 255-255-255-0 s=255,c=3,t=3,pt=0,l=0,st=fail:
    sensor started, id 255
    req node id
    send: 255-255-255-0 s=255,c=3,t=3,pt=0,l=0,st=fail:
    req node id
    send: 255-255-255-0 s=255,c=3,t=3,pt=0,l=0,st=fail:
    req node id
    send: 255-255-255-0 s=255,c=3,t=3,pt=0,l=0,st=fail:
    req node id

    The exact same sketch with the exact same wires, and radio on my Nano work great and I'm getting good communication between the Nano and my gateway.

    I've tried the Uno on USB power as well as AC Adapter power with the same result. The only thing I've not tried is the adding the capacitor to the radio's power, mainly because I don't have one and would have to order it. I've never needed the capacitor before with the Nano, but maybe the Uno's are more finicky? I've put my multimeter to the 3.3v out on the Uno and it looks as stable and correct as can be read with a cheap multimeter.

    Any ideas? I certainly could just go with the Nano at the end of the day but for the application I have in mind, the ability to power it with the AC adapter would make the Uno a better fit...not to mention I have a couple of more Uno's here that I'd hope to use someday as well.

    Thanks in advance,
    Adamv



  • Seems like your node is requuesting a id from a controller. Have you added node address to UNO?
    Here is an example of how to add node id without controller: Node IDs should be between 1-254, because 0 and 255 are reserved.

    int node_id = 1;
    void setup()  
    {
       gw.begin(NULL, node_id);
       //....
    }


  • Thanks for the suggestion, I've never had to manually specify a nodeID before, but I took your advice and did that and it accepted the ID but it's still coming back with the "st=fail" messages:

    connecting at 115200
    send: 119-119-255-255 s=255,c=3,t=7,pt=0,l=0,st=fail:
    sensor started, id 119
    send: 119-119-255-0 s=255,c=0,t=17,pt=0,l=3,st=fail:1.4
    send: 119-119-255-0 s=255,c=3,t=6,pt=1,l=1,st=fail:255
    send: 119-119-255-0 s=255,c=3,t=11,pt=0,l=12,st=fail:Light Sensor
    send: 119-119-255-0 s=255,c=3,t=12,pt=0,l=3,st=fail:1.0
    send: 119-119-255-0 s=0,c=0,t=16,pt=0,l=3,st=fail:1.4
    46
    send: 119-119-255-0 s=0,c=1,t=23,pt=2,l=2,st=fail:46

    I'm not savvy enough in this to know exactly what that st=fail is indicating, I assume it's indicative of the communications failure between the sensor and gateway?

    Anything else to look at?

    thanks!
    Adam



  • Hello, I found this post useful. I had a sensor, 8th on my network, which was not getting the sensor ID from my gateway(ethernet to vera). My other sensors got their ID's no issue.

    Is there anything I possibly did wrong, changed, etc? This new sensor was a "stock" "dallas temperature" sketch from mySensors. All I changed was the sleep time, as I don't need the data so frequently.

    Assigning it its own ID got it recognized in vera, but I have not had to do that before.



  • I am using veralite and ui7. Same problem with Adam Mikolajczyk.

    send: 11-11-255-255 s=255,c=3,t=7,pt=0,l=0,st=fail:
    sensor started, id 11
    send: 11-11-255-0 s=255,c=0,t=17,pt=0,l=5,st=fail:1.4.1
    send: 11-11-255-0 s=255,c=3,t=6,pt=1,l=1,st=fail:255
    send: 11-11-255-0 s=255,c=3,t=11,pt=0,l=13,st=fail:Motion Sensor
    send: 11-11-255-0 s=255,c=3,t=12,pt=0,l=3,st=fail:1.0
    send: 11-11-255-0 s=1,c=0,t=1,pt=0,l=5,st=fail:1.4.1
    0
    send: 11-11-255-0 s=1,c=1,t=16,pt=0,l=1,st=fail:0
    1
    send: 11-11-255-0 s=1,c=1,t=16,pt=0,l=1,st=fail:1
    send: 11-11-255-255 s=255,c=3,t=7,pt=0,l=0,st=fail:
    0
    send: 11-11-255-0 s=1,c=1,t=16,pt=0,l=1,st=fail:0
    1
    send: 11-11-255-0 s=1,c=1,t=16,pt=0,l=1,st=fail:1
    0

    This is my first sensor what is wrong?

    Plugin Version:1.4 Lib Version: 1.4.1 Press start for inclusion 0 devices found

    I am using Nano serial with vera., tried pro mini and uno for motion sensor..


  • Hardware Contributor

    @Adam-Mikolajczyk and @NotYetRated Have you tried to clear Eeprom before loading every(!) new sketch? Strange thing but helped me when using static node-ids.


  • Hardware Contributor

    @C.r.a.z.y. AFAIK UI7 is not yet working. Contact Vera support and ask them to help you downgrade to UI5.



  • @m26872 Thank you very much! This worked for me 👍 💯
    I have another vera lite (ui6 no problem i switch to ui5) and my motion sensor is working.

    Ekran Resmi 2014-11-24 17.58.15.png

    Do you have any idea why Sketch name, version parent node is blank?

    • imp_file was also blank i added it manually "I_MotionSensor1.xml" than restarted.

  • Admin

    @C.r.a.z.y.

    Might require restart of node a couple of time for vera to pick up sketch version/node.


  • Contest Winner

    @Adam-Mikolajczyk

    I have had to use a separate voltage converter vs the on board regulator for 3.3v. It seems that my UNO's 3.3v output may be noisy. It seems that the radio is particularly sensitive to transients.



  • I added a servo and i have only Lib Version 1.4.1. others are blank.
    1 day passed no change.
    ui5 and nano mg995

    I cant control windows covering -up-down- no function

    Any idea?


Log in to reply
 

Suggested Topics

129
Online

10.2k
Users

10.7k
Topics

109.5k
Posts