Vera Lite U17 - Serial Can't Detect Device

  • I have had my serial gateway working for a while, but a while ago it stopped working. It is now saying Can't Detect Device. I'm pretty sure it may have been something I did, but that was months ago, and I'm now back at it. I also need to say I have a USB Hub, and my Insteon USB connection is working fine. I have done the following and have not been able to get past this:

    Created a whole new gateway with a new Nano and radio using the links provided in the MySensors Store.

    Double checked the wiring many times.

    Reinstalled all the MySensors files on the Vera

    Ran ClearEepromConfig

    Removed the Insteon configuration and plugged the Serial Gateway directly into the Vera

    Tried a couple of different USB cables.

    Reinstalled Arduino IDE and MySensors software, and uploaded the sketch into the gateway again.

    In Serial Port configuration made sure the Used by device, baud rate, data bite, and stop bite and parity are correct.

    I'm not sure what the name parameter represents, they were the same and I've tried making that name different.

    I'm not sure what the "Device number" represents and have tried to poke around using Putty to figure this out, but have not figured this out.

    Here is my Serial Port configuration:


    Anyway the adventures continue any ideas would be appreciated.

  • Admin

    Weird. It sure looks like it is connected from the config screen dump.
    How does the "Advanced" tab (or equivalent in UI7) look like for the MySensors Gateway device?

  • Here are screen captures of three of the four tabs in the advanced section. There was nothing under the commands tab.




  • Admin

    Try setting ComFailure to 0 and save device/reload.

  • @Hek - That did it. It is now working, thanks.

  • Hero Member

    @hek Do you know why this fixes it?

    Does vera not retry if ComFailure >0 ??

    On my UI7 test box and test g/w, if I turn off the g/w for whatever reason I find I need to restart luup on Vera to get it to re-establish connection to the g/w.

    So I wonder if it does retry after a period ( which ive never been patient enough for )

  • Admin

    I have no idea why it works. As you say.. it probably doesn't retry if this number is larger than 0. I had the same problem with my Alarm system.

  • To fix that error someone, needs to update the plugin and include this line:
    This way the can't detect message won't be displayed anymore.

  • Admin

    Hmm.. the UI7 branch already have this in place:

  • i had the same issue and it was the serial chip was not apropriate and won't comunicate. ch340,fake ftdi... that kinds won't comunicate propely and cause problems. after change to a FTDI chip all works good

  • Thank you @Tmaster. I put this project away a while ago, and just recently realized after some unrelated reading what the issue must be with this adventure. I'm pretty sure this is what is going on and just have not had the time to get back to it.

  • @hek Thank you so much! That solved the problem for me!!! 🙂

  • @hek This fix worked for me today using Plugin 1.5 Version 2.1.1 on UI7 1.7.2607

Suggested Topics

  • 53
  • 4
  • 3
  • 2
  • 9
  • 10