Domoticz setup with serial gateway?

  • Hi,
    I am totally new to mysensors. I am trying to setup a raspberry pi with domoticz, a mysensors serial gateway and then some nodes.
    I am a bit stuck and do not know exactly where the problem is. I used the github development branch for my libraries and my gateway is the serial gateway on a Arduino Nano clone attached via USB to the raspberry pi and my testnode is the "Humidity Sensor" on an arduino UNO clone. (I changed the gw.begin to
    gw.begin(NULL, 2);
    Serial output on my Humidity sensor:

    send: 2-2-0-0 s=255,c=0,t=17,pt=0,l=5,sg=0,st=fail:1.4.1
    send: 2-2-0-0 s=255,c=3,t=6,pt=1,l=1,sg=0,st=fail:0
    sensor started, id=2, parent=0, distance=255
    send: 2-2-0-0 s=255,c=3,t=11,pt=0,l=8,sg=0,st=fail:Humidity
    send: 2-2-0-0 s=255,c=3,t=12,pt=0,l=3,sg=0,st=fail:1.0
    send: 2-2-0-0 s=0,c=0,t=7,pt=0,l=5,sg=0,st=fail:1.4.1
    send: 2-2-0-0 s=1,c=0,t=6,pt=0,l=5,sg=0,st=fail:1.4.1
    find parent
    send: 2-2-255-255 s=255,c=3,t=7,pt=0,l=0,sg=0,st=bc:
    send: 2-2-0-0 s=1,c=1,t=0,pt=7,l=5,sg=0,st=fail:24.3
    T: 24.30

    Serial output on my Humidity sensor:

    Serial output on my Serial gateway:

    gateway started, id=255, parent=0, distance=1
    0;0;3;0;14;Gateway startup complete.
    0;0;3;0;9;read: 2-2-255 s=255,c=3,t=7,pt=0,l=0,sg=0:
    0;0;3;0;9;read: 2-2-255 s=255,c=3,t=7,pt=0,l=0,sg=0:

    So there is some connection between the two going on, but I do not get any other feedback.

    Does anybody have some ideas?


  • Admin


    You get some failed acks from the node side. Try adding a capacitor to the gateway radio.

  • Hi, thanks for the quick reply. I just tried that, I added a 4.7uF capacitor between VCC and Ground on both, the node and the gateway, and no improvement. I also switched the gateway to another UNO and still the same. I am wondering now, if I might have the wrong radios (I read in another thread here that that might be an issue). I bought them from here:
    I also have some RF69HW here, so I will do another try with them.

    I changed the radios to the RF69HW (and had some trouble to get them working). Eventually I got them started on the node and the gateway, but the output is the same. So it seems also with the other radios I do not get an ACK... Also it seems as if the gateway does not answer to anything...

  • Admin


    Do you see any differences between master/development branch regarding acks for NRF-radio?
    I would probably double check power source and maybe increase capacitor size a notch.
    As you saw in the other thread some of the NRF-clones is hard to distinguish from the real deal.

  • Thanks @hek:
    I just tried the Master branch with the nrf2401+ again.... aaaand it works...
    Since I have no controller attached, for debugging, I fixed the node ID again to 2 for the humidity sensor.

    sensor started, id 2
    send: 2-2-0-0 s=255,c=0,t=17,pt=0,l=5,st=ok:1.4.1
    send: 2-2-0-0 s=255,c=3,t=6,pt=1,l=1,st=ok:0
    send: 2-2-0-0 s=255,c=3,t=11,pt=0,l=8,st=ok:Humidity
    send: 2-2-0-0 s=255,c=3,t=12,pt=0,l=3,st=ok:1.0
    send: 2-2-0-0 s=0,c=0,t=7,pt=0,l=5,st=ok:1.4.1
    send: 2-2-0-0 s=1,c=0,t=6,pt=0,l=5,st=ok:1.4.1
    send: 2-2-0-0 s=1,c=1,t=0,pt=7,l=5,st=ok:20.3
    T: 20.30
    send: 2-2-0-0 s=0,c=1,t=1,pt=7,l=5,st=ok:50.7
    H: 50.70

    Gateway output:

    0;0;3;0;9;read: 2-2-0 s=255,c=0,t=17,pt=0,l=5:1.4.1
    0;0;3;0;9;read: 2-2-0 s=255,c=3,t=6,pt=1,l=1:0
    0;0;3;0;9;read: 2-2-0 s=255,c=3,t=11,pt=0,l=8:Humidity
    0;0;3;0;9;read: 2-2-0 s=255,c=3,t=12,pt=0,l=3:1.0
    0;0;3;0;9;read: 2-2-0 s=0,c=0,t=7,pt=0,l=5:1.4.1
    0;0;3;0;9;read: 2-2-0 s=1,c=0,t=6,pt=0,l=5:1.4.1
    0;0;3;0;9;read: 2-2-0 s=1,c=1,t=0,pt=7,l=5:20.4
    0;0;3;0;9;read: 2-2-0 s=0,c=1,t=1,pt=7,l=5:50.8
    0;0;3;0;9;read: 2-2-0 s=0,c=1,t=1,pt=7,l=5:50.6

    No failed acks anymore (and I did not change the capacitor values, nor an external powersupply). So something seems to be weird in the development branch.
    Too bad, as I was planning to use the RF69HW as radio. But for now I might stick to the Master branch to setup the first sensors. I will debug a bit more at a later stage to try to get the dev branch running.

  • Admin

    Interesting. Hmm.. wonder what could be the issue in dev.

  • To summarize:

    I have the serial gateway now attached to the RaspberryPi which is running domoticz (Beta 2.2339) and it detected the humidity node right away. Both are compiled using the Master branch. I have 4.7uF capacitors between VCC and ground, but not sure if I actually need them. I just pulled them out and it still works flawlessly. Distance is only 20cm though since it is all on my desk. The arduinos I use are Buono UNO clones which have more amp output on the 3.3V rail (200ma).

    If I try to use the serial gateway from the dev branch, I need to do one fix to get it compiled:

    //MySigningNone signer;
    // Construct MySensors library
    MySensor gw(radio);//, signer);

    Otherwise it complains (Using MacOS Arduino 1.6.1). But running that code yields no results. The gateway receives (some) messages from the Humidity node but on the Humidity node all messages fail to get ACKs.

    I do not know why that is. As I said, I am completely new to mysensors, so I did not have time to look deeper into the code yet.
    Shall I open another thread in Troubleshooting? This is not really related to the Domiticz setup anymore...

Log in to reply

Suggested Topics

  • 5
  • 10
  • 6
  • 5
  • 3
  • 5