Solar powered sensor board





  • Hi Ceech,

    Can you post the design files here as well, have seen them on Github, but it will make OpenHardware complete to have them here as well. Another request: can you post the schematic design as a PDF. I think you created the design with eagle? A lot of the people here use Kicad, so won't be able to read the eagle files.

    Thanks in advance,

    Ralph



  • Hi all,

    I like this project, but it looks like the creator is mainly aiming at selling his boards, because there is hardly any documentation posted.
    I would like to challenge the author to show that he is really into Openhardware by sharing more info of this design (like schematics as PDF for the non-eagle users.

    Thx,

    Ralph


  • Hero Member

    well he offres also great service ! and so far it is the best board I have that goes through witer without a glitch !



  • Hi Guys,

    I also bought two of these boards a while ago. I have the NRF, a BH1750 sensor, and cables for battery and solar panel soldered to the board. I'm now trying to upload the sample code to the board. I have the board connected to my Mac as usual through an FTDI adapter. I'm running Arduino 1.8.6. The code compiles fine but cannot upload to the board. The following error is produced:

    "Sketch uses 4266 bytes (13%) of program storage space. Maximum is 30720 bytes.
    Global variables use 312 bytes (15%) of dynamic memory, leaving 1736 bytes for local variables. Maximum is 2048 bytes.
    avrdude: stk500_recv(): programmer is not responding
    avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
    avrdude: stk500_recv(): programmer is not responding"

    I guess the board does not get in flash mode... Settings I use in Arduino are:

    Board: Arduino Pro of Pro Mini
    Processor: "ATMega328 P (3,3V, 8 MHz)

    Any ideas what is going wrong? I would love to see some examples of how the board is used. I want to use it to drive a relay that turns on my DMX controlled lights in my shed. Adding a temp/humidity, motion, and perhaps smoke sensor would be nice too.

    Hope you can help me move forward. Cheers, Roland.


  • Mod

    @roland-wijnen This error is indeed common when the connection to the bootloader fails. Do you know if the ATMega contains a bootloader at all?
    Try to contact @ceech for support.



  • @Yveaux Thanks for your response. I guess that's it. I have to burn a bootloader first :-). I have a USBasp Programmer for that. Can you point me to a wiring diagram that shows how to connect the programmer to the circuit board?


 

317
Online

8.7k
Users

9.5k
Topics

99.5k
Posts