Lua Startup Failure (*SOLVED*)



  • Hi,

    I am trying to get my Veralite working with Arduino and nrf24l01+ Rf Transceiver but it doesnt work for some reason.

    I have uploaded all the plugin files on my Veralite and added a new device, but my device shows an error mesage saying "Lua Startup Failure". When I click on start it gives me another error message saying "Device Not Ready".

    I have my arduino connected to the RF receiver and have uploaded the SerialGateway sketch to it.

    On top of my screen it says : "MySensors plugin : Choose the Serial Port", but when I go to choose the serial port my device doesnt appear there. I have reloded several times and reconnected my arduino to my Veralite via usb but no luck.

    Any suggestions?

    Thanks!!
    error.JPG


  • Admin

    Are you using an Arduino Nano?
    Try restarting Vera (reload luup-engine might not be enough).



  • @hek I am using a nano and have restarted my Vera a few times and still no luck. The nano Im using is a clone, maybe that could be the problem?


  • Admin

    I've heard about a few people losing serial connection intermittently. @clippermiami is one of them if I remember correctly.

    What happens if you add a powered USB hub between gateway and Vera?

    Even if if you are using a clone it would normally be recognized (I'm also using a clone for my gateway).



  • I tried the hub but that didnt work either. Actually the Lua Startup Failure Im seeing on my vera has nothing to do with arduino itself right? I downloaded the latest version of the plugin and reinstalled it but it stills fails to start. I dont know what else to try.


  • Admin

    The MySensors plugin creates the error if no serial device has been configured.
    As a last resort you could convert your serial gateway into an ethernet gateway.

    You could probably get it recognized by ssh:ing into Vera and add the FTDI signature to some config file. But I can't seem to find information about how that was done. It might be buried in some thread on the micasavesde forum.



  • @hek
    So I downloaded the latest mySensors library from Github, reloaded the SerialGateway sketch and redid all my wiring to make sure I wasn't missing anything.
    But now I keep getting a "Version Mismatch" error in the debugger. I noticed the code was updated 3 days ago and I was wondering if some GIT tag or commit Id got messed up in this latest update. I have also updated the Vera plugin.

    By the way, I'm new to the forum and have learned a ton in the last few days reading all of your posts.
    Thanks for sharing your knowledge and helping so many people!
    We appreciate it!


  • Admin

    @rafael.brasilia

    Strange. If you compile both gateway and sensor using the same library version there shouldn't be any mismatch.



  • I am seeing the same issue with my Ethernet gateway. I downloaded the new 1.4, pulled the Ethernet gateway code from the site and uploaded it to my Nano. It complies just fine, but debug shows the following:
    0;0;3;0;14;Gateway startup complete.
    0;0;3;0;9;read: 0-0-0 s=0,c=0,t=0,pt=0,l=0:
    0;0;3;0;9;version mismatch
    0;0;3;0;9;read: 0-0-0 s=0,c=0,t=0,pt=0,l=0:
    0;0;3;0;9;version mismatch
    0;0;3;0;9;read: 0-0-0 s=0,c=0,t=0,pt=0,l=0:
    ...


  • Code Contributor

    @RyanAHolland Did you update your sensors too?



  • I am having a similar problem. U15 GUI has the same "Lua Startup Failure" message and Vera says "Choose the Serial Port". However, everything is working fine ... Vera is communicating to the serial port.

    I've been using this code from the very start (v1.2 days). I first saw this problem after upgrading to v1.4 from 1.4beta. I was able to fix it though by recreating the gateway device and reconfiguring the serial port in U15.

    This morning I loaded "EventWatcher" mios plugin and now seeing the problem again. However, this time I cannot clear the error - even after recreating the gateway device and serial port. But everything is working fine - meaning the serial gw is working.

    Not sure what else to try to clear or fix the error messages?

    Thanks,
    Joe



  • I have the same (almost) issue as @rafael.brasilia.

    Installed the MySensors device with files downloaded today (18/9-14) according to the instructions. When pushing "Reload" after creating the device i had not connected the Gateway to the USB yet. Got the error in the picture below. I then connected the gateway with exactly the same result. Then rebooted and got the same result again.

    Please note! I am using a not supported gateway - the Arduino Pro Mini (the Uno is still on a boat somewhere between here and China :-)), but the issue doesn't seem to be related to the gateway, rather the creation of the device.

    What is my newbee mistake? Except for using the wrong hardware πŸ˜‰

    Untitled.tiff


  • Admin

    Pro Mini and Uno won't be recognized by Vera. You must use Arduino Nano as instructed on the documentation site.



  • @hek ... Sorry, typo - of course it is a Nano I am waiting for.



  • I'm having same problem with my clone NANO.

    I can't get serial adaptor to show up in VERA. I have a powered hub with my VERAlite. I have a usb to serial already for my caddx alarm and usb flash drive for my logs. I have even removed the hub and tried only the nano to the vera. Powered down for a bit and restart. Never can get serial to show up. I can program the NANO and rear the data get a code and startup command.

    Think its my clone? I have an extra UNO but haven't tried it as people said it needed to be a NANO hooked to VERA.



  • @hek
    I bought a Nano today at Electro:Kit MalmΓΆ cuz I just couldn't wait for the boat from China :-)... but the the error remains the same! Reboot, re-download, rewiring, ... I cannot get the MySensors plugin to work.

    BTW, I use codebender and know the software loads OK.

    Any suggestions?



  • @Micke @hek
    Status update: Just stubbled across the

    • "Serial Port Configuration" in the Apps->Develop Apps->Serial Port Configuration tab,
    • selected the "MySensors" device in the drop down,
    • got an error when reloading ("select 115200 baud rate") so I changed the the baud rate
    • reloaded - and no errors!

    Don't know if it works (got not clients/sensors to talk to) but the HUD is all green πŸ™‚


  • Admin

    @Micke

    It's all documented here:
    http://mysensors.org/build/vera



  • @Micke What did you do to make you Serial gateway show up in Vera? I have tried everything you can imagine but my Vera wont recognize it.



  • @rafael.brasilia I followed the instructions in this link.

    Can you give some more information on how far you got, eg:

    • Did you test to upload the blink example to the Nano? Did it work?
    • Was the upload of the Gateway to the Nano successful?
    • Any problems downloading files from Git.hub, uploading these files to Vera?
    • Is the creation successful in the Vera?
      /Micke


  • @Micke

    Yes I did test my Nano with the blink upload and worked fine. I uploaded all the files to Vera with no problem and also uploaded the sketch into my Nano successfully.

    I can even see my Gateway communicating with one of my sensors in the debugger, So I think everything is fine.
    The only problem is when I connect my Gateway to my Vera and go to Serial Port Configuration, there is nothing there. I tried reloding the Luup Engine several times and restarting my Vera, but still no luck.

    Thanks



  • @rafael.brasilia Sorry, I don't know what is wrong. I got problems myself: I can see my Gateway in the Vera... but cannot get it to communicate with the sensors - I am also new to this. Hopefully one of the experienced guys on this site can help you!



  • PROBLEM SOLVED

    So after trying a thousand different things I decided to bite the bulled and bought a Genuine Gravitec Arduino Nano, loaded the Serial Gateway Sketch into it and BOOM! Worked on the first try. My Vera recognized it as soon as I plugged it in.

    For all you guys having problems with Serial Gateway I recommend buying a Gravitec Nano to use as a Gateway. The clones work just fine for the sensors, but not for the Gateway.

    This is the one I bought:
    http://www.ebay.com/itm/400306780486?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1497.l2648


  • Hero Member

    @rafael.brasilia
    Holly cow 35 bucks... Well at least you are up and running. It's strange really, because I had no problems with the Nano from the store vendor.


  • Admin

    This post is deleted!


  • @ServiceXp

    Yeah it was really expensive. But I had tried with 3 different types of clones and none of them worked. You were lucky!



  • @ServiceXp

    Yeah it was really expensive. But I had tried with 3 different types of clones and none of them worked. You were lucky!



  • I had this problem today ( "Lua Startup Failure" / MySensors plugin:Choose Serial Port) after running the serial gateway for a few weeks with no problems.

    I checked the "Serial Port Configuration" under Apps>Develop Apps and the baud was mysteriously set at 9600. I reset it to 115200 and reloaded Vera and everything reset fine. Is there any known reason why the baud setting would change on its own? Conflict with another plugin, perhaps datamine)?


  • Hero Member

    @rafael.brasilia: Did you try powering the clones using an external power supply connected to Vin.

    That solved some problems I had getting an Ethernet gateway up-and-running.



  • Check your Nano, if you have the one with CH340 usb chipset will not work for serial gateway. It will work if you use it for a node. Need to get another nano with FTDI chipset for serial gateway and it will work. I have the same problem and even try many different ways still won't work until I figure it out from the other post. You don't need to buy the one for $35 bucks, search on Ali.... you still find some sellers sell Nano with FTDI chipset for @ $7 bucks. Hope it help and save your time.



  • I'll admit a newbie at this. but I"m about beyond frustrated. I've been trying to get my "Vera Edge" Serial gateway up and running. I had it working, using a nano ATmega328 w/FTDI chipset. So that was great! All your posts were very helpful! So I decided to move forward and start building my sensors. The first sensor I built was a motion sensor also using a nano ATmega328. So I got it up and running, communicating with the gateway, and than the Vera controller dropped it and I kept get the same error message, Device not ready, "LUA Startup Failure.
    If you all have any another ideas on what could be causing this I could sure use your help!
    Thanks


 

293
Online

8.9k
Users

9.6k
Topics

100.9k
Posts