💬 Building a Raspberry Pi Gateway

  • Hardware Contributor

    Was my fault!
    **When copy and past command from word, for example, pay attention that software doesn't substitute the single "-" with a "-" longer. 😵

    I have a word with all commands, to replicate installation very fast. Was my fault (errr... Word fault.... but you understand). Have a nice day!

    I cannot go over the initialization of command.

    RPI3 + Amplified antenna by GertSander (https://www.openhardware.io/view/17/Raspberry-Pi2-GPIO-interface-for-NRF24L01). Power from 5v/3A and power for antenna taken from both 5V via the 3.3v stepper down.

    RPI3 is new, has about 12h (got yesterday).

    Yesterday it did work at first attempt. Today I would replicate so I did delete the uSD and restart over. No way to get the gateway on work.

    I did try 3 amplified antenna + 2 normal. No way.

    I did enable from raspi-config the SPI (and only it).

    It hangs on second line of output.

    These are the logs:

    sineverba@raspberrypi:~/MySensors $ ./configure --my-transport=nrf24 --my-gateway=serial --my-serial-is-pty --my-serial-pty=/dev/ttyUSB020
    [SECTION] Detecting target machine.
      [OK] machine detected: SoC=BCM2837, Type=rpi3, CPU=armv7l.
    [SECTION] Detecting SPI driver.
      [OK] SPI driver detected:BCM.
    [SECTION] Detecting init system.
      [OK] init system detected: systemd.
    [SECTION] Saving configuration.
    [SECTION] Cleaning previous builds.
    [OK] Finished.
    sineverba@raspberrypi:~/MySensors $ make
    gcc -MT build/drivers/Linux/log.o -MMD -MP -march=armv8-a+crc -mtune=cortex-a53 -mfpu=neon-fp-armv8 -mfloat-abi=hard -DMY_RADIO_NRF24 -DMY_GATEWAY_SERIAL -DMY_DEBUG -DLINUX_SPI_BCM -DLINUX_ARCH_RASPBERRYPI -DMY_LINUX_SERIAL_PTY=\"/dev/ttyUSB020\" -DMY_LINUX_IS_SERIAL_PTY  -Ofast -g -Wall -Wextra  -I. -I./core -I./drivers/Linux -I./drivers/BCM -c drivers/Linux/log.c -o build/drivers/Linux/log.o
    g++ -MT build/drivers/Linux/IPAddress.o -MMD -MP -march=armv8-a+crc -mtune=cortex-a53 -mfpu=neon-fp-armv8 -mfloat-abi=hard -DMY_RADIO_NRF24 -DMY_GATEWAY_SERIAL -DMY_DEBUG -DLINUX_SPI_BCM -DLINUX_ARCH_RASPBERRYPI -DMY_LINUX_SERIAL_PTY=\"/dev/ttyUSB020\" -DMY_LINUX_IS_SERIAL_PTY  -Ofast -g -Wall -Wextra  -I. -I./core -I./drivers/Linux -I./drivers/BCM -c drivers/Linux/IPAddress.cpp -o build/drivers/Linux/IPAddress.o
    g++ -MT build/drivers/Linux/noniso.o -MMD -MP -march=armv8-a+crc -mtune=cortex-a53 -mfpu=neon-fp-armv8 -mfloat-abi=hard -DMY_RADIO_NRF24 -DMY_GATEWAY_SERIAL -DMY_DEBUG -DLINUX_SPI_BCM -DLINUX_ARCH_RASPBERRYPI -DMY_LINUX_SERIAL_PTY=\"/dev/ttyUSB020\" -DMY_LINUX_IS_SERIAL_PTY  -Ofast -g -Wall -Wextra  -I. -I./core -I./drivers/Linux -I./drivers/BCM -c drivers/Linux/noniso.cpp -o build/drivers/Linux/noniso.o
    g++ -MT build/drivers/Linux/GPIO.o -MMD -MP -march=armv8-a+crc -mtune=cortex-a53 -mfpu=neon-fp-armv8 -mfloat-abi=hard -DMY_RADIO_NRF24 -DMY_GATEWAY_SERIAL -DMY_DEBUG -DLINUX_SPI_BCM -DLINUX_ARCH_RASPBERRYPI -DMY_LINUX_SERIAL_PTY=\"/dev/ttyUSB020\" -DMY_LINUX_IS_SERIAL_PTY  -Ofast -g -Wall -Wextra  -I. -I./core -I./drivers/Linux -I./drivers/BCM -c drivers/Linux/GPIO.cpp -o build/drivers/Linux/GPIO.o
    g++ -MT build/drivers/Linux/SPIDEV.o -MMD -MP -march=armv8-a+crc -mtune=cortex-a53 -mfpu=neon-fp-armv8 -mfloat-abi=hard -DMY_RADIO_NRF24 -DMY_GATEWAY_SERIAL -DMY_DEBUG -DLINUX_SPI_BCM -DLINUX_ARCH_RASPBERRYPI -DMY_LINUX_SERIAL_PTY=\"/dev/ttyUSB020\" -DMY_LINUX_IS_SERIAL_PTY  -Ofast -g -Wall -Wextra  -I. -I./core -I./drivers/Linux -I./drivers/BCM -c drivers/Linux/SPIDEV.cpp -o build/drivers/Linux/SPIDEV.o
    g++ -MT build/drivers/Linux/Print.o -MMD -MP -march=armv8-a+crc -mtune=cortex-a53 -mfpu=neon-fp-armv8 -mfloat-abi=hard -DMY_RADIO_NRF24 -DMY_GATEWAY_SERIAL -DMY_DEBUG -DLINUX_SPI_BCM -DLINUX_ARCH_RASPBERRYPI -DMY_LINUX_SERIAL_PTY=\"/dev/ttyUSB020\" -DMY_LINUX_IS_SERIAL_PTY  -Ofast -g -Wall -Wextra  -I. -I./core -I./drivers/Linux -I./drivers/BCM -c drivers/Linux/Print.cpp -o build/drivers/Linux/Print.o
    g++ -MT build/drivers/Linux/EthernetClient.o -MMD -MP -march=armv8-a+crc -mtune=cortex-a53 -mfpu=neon-fp-armv8 -mfloat-abi=hard -DMY_RADIO_NRF24 -DMY_GATEWAY_SERIAL -DMY_DEBUG -DLINUX_SPI_BCM -DLINUX_ARCH_RASPBERRYPI -DMY_LINUX_SERIAL_PTY=\"/dev/ttyUSB020\" -DMY_LINUX_IS_SERIAL_PTY  -Ofast -g -Wall -Wextra  -I. -I./core -I./drivers/Linux -I./drivers/BCM -c drivers/Linux/EthernetClient.cpp -o build/drivers/Linux/EthernetClient.o
    g++ -MT build/drivers/Linux/compatibility.o -MMD -MP -march=armv8-a+crc -mtune=cortex-a53 -mfpu=neon-fp-armv8 -mfloat-abi=hard -DMY_RADIO_NRF24 -DMY_GATEWAY_SERIAL -DMY_DEBUG -DLINUX_SPI_BCM -DLINUX_ARCH_RASPBERRYPI -DMY_LINUX_SERIAL_PTY=\"/dev/ttyUSB020\" -DMY_LINUX_IS_SERIAL_PTY  -Ofast -g -Wall -Wextra  -I. -I./core -I./drivers/Linux -I./drivers/BCM -c drivers/Linux/compatibility.cpp -o build/drivers/Linux/compatibility.o
    g++ -MT build/drivers/Linux/SerialPort.o -MMD -MP -march=armv8-a+crc -mtune=cortex-a53 -mfpu=neon-fp-armv8 -mfloat-abi=hard -DMY_RADIO_NRF24 -DMY_GATEWAY_SERIAL -DMY_DEBUG -DLINUX_SPI_BCM -DLINUX_ARCH_RASPBERRYPI -DMY_LINUX_SERIAL_PTY=\"/dev/ttyUSB020\" -DMY_LINUX_IS_SERIAL_PTY  -Ofast -g -Wall -Wextra  -I. -I./core -I./drivers/Linux -I./drivers/BCM -c drivers/Linux/SerialPort.cpp -o build/drivers/Linux/SerialPort.o
    g++ -MT build/drivers/Linux/Stream.o -MMD -MP -march=armv8-a+crc -mtune=cortex-a53 -mfpu=neon-fp-armv8 -mfloat-abi=hard -DMY_RADIO_NRF24 -DMY_GATEWAY_SERIAL -DMY_DEBUG -DLINUX_SPI_BCM -DLINUX_ARCH_RASPBERRYPI -DMY_LINUX_SERIAL_PTY=\"/dev/ttyUSB020\" -DMY_LINUX_IS_SERIAL_PTY  -Ofast -g -Wall -Wextra  -I. -I./core -I./drivers/Linux -I./drivers/BCM -c drivers/Linux/Stream.cpp -o build/drivers/Linux/Stream.o
    g++ -MT build/drivers/Linux/interrupt.o -MMD -MP -march=armv8-a+crc -mtune=cortex-a53 -mfpu=neon-fp-armv8 -mfloat-abi=hard -DMY_RADIO_NRF24 -DMY_GATEWAY_SERIAL -DMY_DEBUG -DLINUX_SPI_BCM -DLINUX_ARCH_RASPBERRYPI -DMY_LINUX_SERIAL_PTY=\"/dev/ttyUSB020\" -DMY_LINUX_IS_SERIAL_PTY  -Ofast -g -Wall -Wextra  -I. -I./core -I./drivers/Linux -I./drivers/BCM -c drivers/Linux/interrupt.cpp -o build/drivers/Linux/interrupt.o
    g++ -MT build/drivers/Linux/SerialSimulator.o -MMD -MP -march=armv8-a+crc -mtune=cortex-a53 -mfpu=neon-fp-armv8 -mfloat-abi=hard -DMY_RADIO_NRF24 -DMY_GATEWAY_SERIAL -DMY_DEBUG -DLINUX_SPI_BCM -DLINUX_ARCH_RASPBERRYPI -DMY_LINUX_SERIAL_PTY=\"/dev/ttyUSB020\" -DMY_LINUX_IS_SERIAL_PTY  -Ofast -g -Wall -Wextra  -I. -I./core -I./drivers/Linux -I./drivers/BCM -c drivers/Linux/SerialSimulator.cpp -o build/drivers/Linux/SerialSimulator.o
    g++ -MT build/drivers/Linux/SoftEeprom.o -MMD -MP -march=armv8-a+crc -mtune=cortex-a53 -mfpu=neon-fp-armv8 -mfloat-abi=hard -DMY_RADIO_NRF24 -DMY_GATEWAY_SERIAL -DMY_DEBUG -DLINUX_SPI_BCM -DLINUX_ARCH_RASPBERRYPI -DMY_LINUX_SERIAL_PTY=\"/dev/ttyUSB020\" -DMY_LINUX_IS_SERIAL_PTY  -Ofast -g -Wall -Wextra  -I. -I./core -I./drivers/Linux -I./drivers/BCM -c drivers/Linux/SoftEeprom.cpp -o build/drivers/Linux/SoftEeprom.o
    g++ -MT build/drivers/Linux/EthernetServer.o -MMD -MP -march=armv8-a+crc -mtune=cortex-a53 -mfpu=neon-fp-armv8 -mfloat-abi=hard -DMY_RADIO_NRF24 -DMY_GATEWAY_SERIAL -DMY_DEBUG -DLINUX_SPI_BCM -DLINUX_ARCH_RASPBERRYPI -DMY_LINUX_SERIAL_PTY=\"/dev/ttyUSB020\" -DMY_LINUX_IS_SERIAL_PTY  -Ofast -g -Wall -Wextra  -I. -I./core -I./drivers/Linux -I./drivers/BCM -c drivers/Linux/EthernetServer.cpp -o build/drivers/Linux/EthernetServer.o
    g++ -MT build/examples_linux/mysgw.o -MMD -MP -march=armv8-a+crc -mtune=cortex-a53 -mfpu=neon-fp-armv8 -mfloat-abi=hard -DMY_RADIO_NRF24 -DMY_GATEWAY_SERIAL -DMY_DEBUG -DLINUX_SPI_BCM -DLINUX_ARCH_RASPBERRYPI -DMY_LINUX_SERIAL_PTY=\"/dev/ttyUSB020\" -DMY_LINUX_IS_SERIAL_PTY  -Ofast -g -Wall -Wextra  -I. -I./core -I./drivers/Linux -I./drivers/BCM -c examples_linux/mysgw.cpp -o build/examples_linux/mysgw.o
    gcc -MT build/drivers/BCM/bcm2835.o -MMD -MP -march=armv8-a+crc -mtune=cortex-a53 -mfpu=neon-fp-armv8 -mfloat-abi=hard -DMY_RADIO_NRF24 -DMY_GATEWAY_SERIAL -DMY_DEBUG -DLINUX_SPI_BCM -DLINUX_ARCH_RASPBERRYPI -DMY_LINUX_SERIAL_PTY=\"/dev/ttyUSB020\" -DMY_LINUX_IS_SERIAL_PTY  -Ofast -g -Wall -Wextra  -I. -I./core -I./drivers/Linux -I./drivers/BCM -c drivers/BCM/bcm2835.c -o build/drivers/BCM/bcm2835.o
    g++ -MT build/drivers/BCM/BCM.o -MMD -MP -march=armv8-a+crc -mtune=cortex-a53 -mfpu=neon-fp-armv8 -mfloat-abi=hard -DMY_RADIO_NRF24 -DMY_GATEWAY_SERIAL -DMY_DEBUG -DLINUX_SPI_BCM -DLINUX_ARCH_RASPBERRYPI -DMY_LINUX_SERIAL_PTY=\"/dev/ttyUSB020\" -DMY_LINUX_IS_SERIAL_PTY  -Ofast -g -Wall -Wextra  -I. -I./core -I./drivers/Linux -I./drivers/BCM -c drivers/BCM/BCM.cpp -o build/drivers/BCM/BCM.o
    g++ -MT build/drivers/BCM/SPIBCM.o -MMD -MP -march=armv8-a+crc -mtune=cortex-a53 -mfpu=neon-fp-armv8 -mfloat-abi=hard -DMY_RADIO_NRF24 -DMY_GATEWAY_SERIAL -DMY_DEBUG -DLINUX_SPI_BCM -DLINUX_ARCH_RASPBERRYPI -DMY_LINUX_SERIAL_PTY=\"/dev/ttyUSB020\" -DMY_LINUX_IS_SERIAL_PTY  -Ofast -g -Wall -Wextra  -I. -I./core -I./drivers/Linux -I./drivers/BCM -c drivers/BCM/SPIBCM.cpp -o build/drivers/BCM/SPIBCM.o
    g++ -MT build/drivers/BCM/Wire.o -MMD -MP -march=armv8-a+crc -mtune=cortex-a53 -mfpu=neon-fp-armv8 -mfloat-abi=hard -DMY_RADIO_NRF24 -DMY_GATEWAY_SERIAL -DMY_DEBUG -DLINUX_SPI_BCM -DLINUX_ARCH_RASPBERRYPI -DMY_LINUX_SERIAL_PTY=\"/dev/ttyUSB020\" -DMY_LINUX_IS_SERIAL_PTY  -Ofast -g -Wall -Wextra  -I. -I./core -I./drivers/Linux -I./drivers/BCM -c drivers/BCM/Wire.cpp -o build/drivers/BCM/Wire.o
    g++ -MT build/drivers/BCM/RPi.o -MMD -MP -march=armv8-a+crc -mtune=cortex-a53 -mfpu=neon-fp-armv8 -mfloat-abi=hard -DMY_RADIO_NRF24 -DMY_GATEWAY_SERIAL -DMY_DEBUG -DLINUX_SPI_BCM -DLINUX_ARCH_RASPBERRYPI -DMY_LINUX_SERIAL_PTY=\"/dev/ttyUSB020\" -DMY_LINUX_IS_SERIAL_PTY  -Ofast -g -Wall -Wextra  -I. -I./core -I./drivers/Linux -I./drivers/BCM -c drivers/BCM/RPi.cpp -o build/drivers/BCM/RPi.o
    g++ -pthread  -o bin/mysgw build/drivers/Linux/log.o build/drivers/Linux/IPAddress.o build/drivers/Linux/noniso.o build/drivers/Linux/GPIO.o build/drivers/Linux/SPIDEV.o build/drivers/Linux/Print.o build/drivers/Linux/EthernetClient.o build/drivers/Linux/compatibility.o build/drivers/Linux/SerialPort.o build/drivers/Linux/Stream.o build/drivers/Linux/interrupt.o build/drivers/Linux/SerialSimulator.o build/drivers/Linux/SoftEeprom.o build/drivers/Linux/EthernetServer.o build/examples_linux/mysgw.o build/drivers/BCM/bcm2835.o build/drivers/BCM/BCM.o build/drivers/BCM/SPIBCM.o build/drivers/BCM/Wire.o build/drivers/BCM/RPi.o
    sineverba@raspberrypi:~/MySensors $ sudo ./bin/mysgw –d
    [sudo] password for sineverba:
    mysgw: Starting gateway...
    mysgw: Protocol version - 2.2.0-rc.2

  • Hardware Contributor

    Hi to all,
    I'm testing an ethernet gateway on RPI3, with nrf24 + 1 node with a relay.

    I want introduce security and signing. On Arduino gateway / node no problem at all, but, how to do on the RPI3 as gateway?

    I would get / create / set a software serial on PI itself and whitelisting it on the node, after I will introduce the AES Key and signing.

    Cannot find in documentation how do it on PI3. Thank you very much!

  • @sineverba said in 💬 Building a Raspberry Pi Gateway:

    Hi to all,
    I'm testing an ethernet gateway on RPI3, with nrf24 + 1 node with a relay.

    I want introduce security and signing. On Arduino gateway / node no problem at all, but, how to do on the RPI3 as gateway?

    I would get / create / set a software serial on PI itself and whitelisting it on the node, after I will introduce the AES Key and signing.

    Cannot find in documentation how do it on PI3. Thank you very much!

    Earlier in this forum... https://forum.mysensors.org/topic/4803/building-a-raspberry-pi-gateway/350

  • @mfalkvidd I'm trying today, but to compile correctly the Docker image I'll have to clone to my github account 😞 or at least locally. My Dockerfile for the "Alpine edition" for Hass.io is simply:

    ENV CONFIG_PATH=/data/options.json
    ENV APPDIR=/opt/MySensors
    RUN apt-get update && apt-get install -y --force-yes \
        make \
    	 g++ \
    	 git \
    	 && rm -rf /var/lib/apt/lists/* /tmp/* /var/tmp/* ~/.cache \
    	 && git clone https://github.com/mysensors/MySensors.git --branch development $APPDIR
    # Copy root filesystem
    COPY rootfs /
    #CMD [ "/run.sh" ]

    I deleted the LABELS 'cause... the data is still too rawly "buried" from others. 👅

    The Configure and Make is in run.sh.

    BTW, I still need to figure out how to start mysgw as service... Mainlyt I'd like to redirect the log: how can I do this safely?

    And... can I use the rx/tx/err led feature on Raspi too (aside being in a Docker) ?

    EDIT: the code add works!
    Another question: I'm not getting far from this... what is it trying to do?

    : Starting gateway...
    : Protocol version - 2.2.0-rc.2
    : MCO:BGN:INIT GW,CP=RNNGL---,VER=2.2.0-rc.2
    : TSF:LRT:OK
    : TSM:INIT
    : TSF:WUR:MS=0

  • Hardware Contributor

    @ghiglie Thank you, I did see that was for 2.1.1. Just playing with them!

  • Plugin Developer

    Does the Pi Gateway support the MY_SIGNING_SIMPLE_PASSWD option? I couldn't find anything about that. I've been gearing up to use that feature in my network, but I've also been playing with moving my gateway onto my Pi Zero W.

  • Mod

    @alowhum If you want to just encrypt data, just add the encryption key in the myconfig.h file and compile it

  • @gohan N00b question, but which steps from the step-by-step need to be redone to "compile it" after altering myconfig.h? Or can you just post the command lines? 😳

  • Mod

    As soon as you do the changes in myconfig.h before the MAKE, you are fine

  • Anyone tried using the new Pi Zero WH as a Raspberry Pi Gateway. Presumably by MQTT and using NRF24 radio?

    @alowhum Have you been able to setup a gateway with your Raspberry Pi Zero?

  • @sentur That's what I'm doing now. Except mine is Zero W. Soldered the pins on myself.

  • Code Contributor

    @alowhum yes, to use MY_SIGNING_SIMPLE_PASSWD feature, add the following to your list of configure options:

    ... --my-signing=password --my-signing-password=<PASSWORD>

  • Is there anyway where i can see if i have IRQ configured ?
    ive build it a long time ago, but now upgraded to a nrf24 PA/LNA and have more an more sensors.

  • Mod

    look inside makefile.inc in mysensors folder, that should contain the parameters you set in ./configure

  • @gohanm, as it seems not ?, can i rebuild it easily? ```

    CPPFLAGS=-march=armv8-a+crc -mtune=cortex-a53 -mfpu=neon-fp-armv8 -mfloat-abi=hard -DMY_RADIO_NRF24 -DMY_GATEWAY_LINUX -DMY_DEBUG -DLINUX_SPI_BCM -DLINUX_ARCH_RASPBERRYPI -DMY_PORT=5003

  • Mod

    make a copy of it and make a ./configure with the IRQ enabled and see what you get

  • @gohan make a copy of the makefile.inc and restart the ./configure command again you mean ?
    ill try it tomorrow, too afraid to break things late in the evening 😉

  • Mod

    as far as you don't execute the MAKE command you are ok. Also make a copy of the mysgw executable just as backup if you never did it

  • but ill have to do it sometime , just ./configure with all the options, build , test and install ?

  • Mod

    if you only want to check if irq is enabled, otherwise you could just build it fresh with irq enabled and you can go back by replacing the mysgw executable

  • @gohan ty

  • This post is deleted!

  • Moved to normal troubleshooting forum

  • This post is deleted!

  • Plugin Developer

    @MasMat Yes I was able to build it on a Pi Zero. I did a fresh install on Dietpi. It worked fine when I didn't give any configuration options.

    Now, however, I am still trying to run something on the PGIO pins in paralel to MySensors again, and this is not working. As I speak the Pi reboots every 5 minutes.. Not sure what to blame yet. Domoticz, PiGPIO, or MySensors.

    Latest DietPi Stretch, latest Domoticz beta, latest MySensors beta.

  • Mod

    @alowhum said in 💬 Building a Raspberry Pi Gateway:


    what are you using that for?

  • @alowhum I'm not using the GPIO for anything else.
    I had everything working (mysgw-MQTT, Mosquitto, Node-Red and OH2) for almost 6h. Then I moved the set-up and everything went south: cant get mosquitto to start, cant get mysgw to connect to that or another Mosquitto broker, OH2 seems to ignore everything...
    Spent the last 24h trying to resurrect Mosquitto but it's beyond me what's wrong.

    I remember reading that mysgw renders rest of the gpio unusable. Maybe that's giving you problems.

  • Mod

    I am running 2 gateway instances, one nrf24 and one rfm69 so I guess you can run other things

  • Plugin Developer

    @gohan: but you had to do a lot of black magic to get there right?

  • Mod

    not at all, I just followed the guide in the forum

  • Plugin Developer

    @masmat I got the Pi Zero W working fine with other things using the GPIO.

    • A fresh install helped
    • It could be that I now use the PiGPIO library for the project.
    • It could be the switch to another powersupply. I was using the official pi powersupply, but I suspect something was wrong with it. A cheap 3A chinese adapter is working fine.

    Either way: it all works now.

    I have a few n00bish questions about enabling encryption (without signing, so save space and ram):

    • Is putting an AES key in MyConfig.h really all I have to do? Don't I also have to put that in all the sensor nodes? And is that proces complicated, using a signing sketch and whatnot?
    • Can I have an 'opportunistic' network, where I have some encrypted nodes, and some unencrypted ones? If I could mix them this would make switching to encryption less stressful. I can't easily change two of my nodes.
    • If I change the network, I'd like to move the NRF to channel 100 (juist outside of the normal WiFi frequencies). Do I also have to set that in all nodes, or is setting it in the gateway enough?

  • Contest Winner

    @alowhum encryption is all or nothing. You can't leave one node without encryption if your gateway encrypts the messages it send.
    And you will need to personalize your nodes to get the AES key into them. The documentation on security describes that process.

  • Mod

    @alowhum if you put it in myconfig.h also on the arduino library you can just recompile the nodes and you are good.

  • Contest Winner

    @gohan not anymore. Only for pre 2.2.0 releases.

  • Mod

    It is still working on mine 😅

  • Contest Winner

    @gohan in other words, you use an old release 😉

  • Mod

    I can assure you I am using 2.2 from development as I am also running new driver. So unless you changed something in the last 3 weeks on the development branch it still works, unless the nodes are keeping the key saved.

  • Contest Winner

    @gohan have you verified your communications are actually encrypted?

  • Contest Winner

    @gohan If you see here, you will find that unless you use the simple password option, AES key is fetched from EEPROM: https://github.com/mysensors/MySensors/blob/28c4f3f19e7026f56fd9bbc61d566f770fd7a9d2/hal/transport/MyTransportRF24.cpp#L68
    So either you are using the simple flag, nothing at all, or not using the key you think you use.

  • Mod

    I ll have to check, but I put the key in the gateway myconfig.h

  • Contest Winner

    @gohan Perhaps on a rpi GW where there is no EEPROM, but I am talking about the nodes.

  • Mod

    Well, if I have communication working it means the node should be encrypting data. I'll have to try with clear eeprom and try flashing sketch again

  • Contest Winner

    @gohan not if there is no encryption at all. You could try to use simple password option on a node with various passwords and see if it is detected by your gw at all.

  • Mod

    @anticimex I guess you were right... the gw and node aren't using the AES key. So where am I supposed to add it in the gateway?

  • Contest Winner

    @gohan you set that with the configure arguments I suspect, but I can't see it in the documentation. @marceloaqno perhaps knows how the rPi port handles this. I'm on a phone so I can't check the code easily. But you should be able to find it in the transport driver for rPi. On the rPi it can probably be defined in the code as it does not have a personalizer.

  • Mod

    @anticimex It doesn't read it from the mysonfig.h for sure as it is where I always put it

  • Contest Winner

    @gohan MyConfig.h does to my knowledge not have a define value for that. You cannot add new definitions to it and expect them to have an effect. If there is one already defined in there, as a comment or not, and it does not have an effect, please report a bug on it.

  • @macvictor
    I followed all the step that you mentioned in your post to establish the serial gateway. However I am still not able to receive the message from arduino. Could you please what to do?

    import RPi.GPIO as GPIO
    from lib_nrf24 import NRF24
    import time
    import spidev


    pipes = [[0xE8, 0xE8, 0xF0, 0xF0, 0xE1], [0xF0, 0xF0, 0xF0, 0xF0, 0xE1]]
    radio = NRF24(GPIO, spidev.SpiDev())


    radio.setPALevel (NRF24.PA_MAX)
    radio.openReadingPipe(1 ,pipes[1])

    Please find below my raspberry code..can you please suggest , if there is any issue with code or am I missing anything ?

  • Mod

    @rajeev2301 please don't split our effort to help you into multiple threads. It wastes people's time when some information is in one thread and some in another thread.

  • To upgrade to the latest release, can I use git pull, or is it better to delete the directory and start again?

  • Contest Winner

    @wes you can pull. Just as long as you verify that your working directory is clean or only contains changes you intend to have. And you have the appropriate branch or tag checked out.

  • @macvictor
    Is any chance to add security & signing for radio RFM69HW ? Please help me how ?

  • Contest Winner

    @pepson signing is radio agnostic. It has nothing to do with the radio.

  • Hardware Contributor

    @anticimex @wes Can I please ask how to update? I mean, the right command to type.
    I have the folder "MySensors" on documents of my user in Pi:


    Of course I have all installed and perfectly working now (I'm on the 2.2.0 rc2).

    I need also to relaunch the ./config command?

    Thank you to both and all!

  • Contest Winner

  • Hello, I configure the raspberry gateway to use MQTT. I set mosquitto as the broker. The problem that I encounter is that when I subscribe to test if the gateway publish on the broker, I have empty message. So my first guess is that there is an issue somewhere which cause that only empty message are sent.

    Here is my arduino code : https://pastebin.com/YKi4EAad
    The RasperryPI3 config & logs : https://pastebin.com/Kjn8CC8A
    The MQTT Client logs : https://pastebin.com/ZP8GrkTj

  • Regarding the communication issues described in the instructions page with the 2.2 stable version, is that still valid and still recommended to use the development branch?

  • Mod

    Go for stable now, I need to remove that line from the page

  • @gohan Thank you verys muchos. 👍

  • Code Contributor

    @syna It is empty because it's a message of type I_ID_REQUEST that your node is sending. You need to set up a controller to distribute IDs or you can set it manually by adding this to your node's sketch:

    #define MY_NODE_ID X

    where X is a unique number from 1 to 254.

  • Hardware Contributor

    Hi to all,
    tonight I made update from 2.2.0 RC2 to 2.2.0 (stable) on my Raspberry PI3.
    It is a live system (my heater control).

    By the way the update is very simple.

    First of all, backup or better CLONE your PI.

    1 - Disable the daemon with

    sudo systemctl stop mysgw.service && sudo systemctl disable mysgw.service

    2 - Make a copy of the MySensors folder ( I made a copy with the name of version coming, so...)

    cp -r MySensors MySensorsX.X.X(rc2)/

    (the slash at the end means "It's a folder!"

    3 - Remove the MySensors folder

    sudo rm -r MySensors

    4 - Git the "new" MySensors folder && configure it as usual. Remember to activate the daemon and see on Domoticz (for example) the gateway with new version 🙂

  • Hi,

    I am running the current version (2.2.0) on a RPi 1.
    I noticed that sometimes the cpu usage of the service is increasing dramatically (around 90% and more) - and then the service stops working.
    As I am not a C-Pro, I wrote a little python-script, which is called every minute by cron and restarts the service, if it uses more than 50% cpu.
    Maybe someone will find it useful:

    # -*- coding: utf-8 -*-
    import psutil, sys, os, datetime
    PY3 = sys.version_info[0] == 2
    LOOKFOR = u"mysgw"
    for proc in psutil.process_iter():
        if proc.name() == "mysgw":
            dt = str(datetime.datetime.now()).split('.')[0]
            cpu = proc.cpu_percent(interval=1)
            if cpu > 50:
                    print(dt + " high CPU-usage! --> restarting service")
                    os.system("/bin/systemctl restart mysgw.service")
                    if datetime.datetime.now().strftime('%M') == "45":
                            print(dt + " everything OK, cpu: " + str(cpu))

    and the crontab-entry (as root):

    * * * * * /home/pi/pstest.sh >> /var/log/mysgw-logger.log


  • @otto001 Thanks for that! I'm also getting this annoying service failure on 2.2 on a RPi 2. It seems to happen at random at night when nothing much is going on in the house. It probably happens once every 1 to 2 weeks.
    CPU use is almost 100% and the service stops working.
    Are there any logs I can check? I'd prefer to know what's wrong although I'll go with the auto restart on high cpu use to prevent the house from ceasing to function at random!

  • Plugin Developer

    I once noticed this too, on a pi zero system with domoticz beta.

  • @Nick-Willis:
    I do run the gateway in debug mode, but I could not see anything special.
    Yesterday the service was auto-restarted by my script:

    2018-02-27 13:31:03 high CPU-usage! --> restarting service```

    On the same time in the "normal" mysgw.log (debugging enabled) (should be syslog normally, but I changed the logfile location for better investigation):

    Feb 27 13:30:36 raspiez mysgw: TSF:MSG:READ,14-14-0,s=1,c=1,t=23,pt=7,l=5,sg=0:0.11
    Feb 27 13:30:36 raspiez mysgw: TSF:MSG:READ,14-14-0,s=3,c=1,t=0,pt=7,l=5,sg=0:21.9
    Feb 27 13:30:36 raspiez mysgw: TSF:MSG:READ,14-14-0,s=4,c=1,t=1,pt=7,l=5,sg=0:31.4
    Feb 27 13:30:38 raspiez mysgw: New connection from <-- fhem re-connects
    Feb 27 13:30:38 raspiez mysgw: GWT:TSA:C=1,CONNECTED
    Feb 27 13:31:04 raspiez mysgw: Received SIGTERM <-- AUTO-Restart

    The only thing that is a little bit unusual is the re-connect of my controller (fhem) - but this happens every 30 minutes for stability reasons.
    This should not happen, but I can not find out what the problem is.

    Maybe you could also enable debugging by changing the following file (maybe we can find a pattern why this is happening):





    ExecStart=/usr/local/bin/mysgw -d

    Please do not forget to issue a

    sudo systemctl daemon-reload 

    followed by

    sudo systemctl restart mysgw.service

    to enable the change.

    My restarting-script might help until someone with better knowledge finds a solution...
    I also will have an eye on the logs for findig out how often this is happening...


  • Code Contributor

    Please, could all of you who experienced this issue post the configuration options you used to build the gateway?
    This would help to investigate the problem.

  • @marceloaqno : of course, thanks for the hint!

    I had the following configure:

    ./configure --my-transport=nrf24 --my-rf24-irq-pin=15 --my-gateway=ethernet --my-port=5004

    (The high CPU problem also occured before I connected PIN 15 to IRQ without the corresponding config option. I hoped to solve the Problem using IRQ, but this did not help. And I have a second GW with default port 5003 in my network. This is running an ancient version of Raspi GW Software and this is working fine -but slower). I am using current fhem as controller and I have it connecting every 30 minutes to the gateways due to stability issues in the past. There are only about 6 nodes (just motion, humidity & temp and lux) connected to this gateway.

    In addition to that I changed the default channel in MyConfig.h (because I have two different MySensor networks):

    #ifndef MY_RF24_CHANNEL
    #define MY_RF24_CHANNEL (82)

    I am pretty sure, that this is not important, but I also set up rsyslog to write gw logs to an own file instead of syslog....

    Maybe this helps.


  • Code Contributor

  • @marceloaqno : Wow, you are fast! Thanks!
    Just applied the patch and recompiled. I will report in a couple of days while my monitoring-script is still running (and logging)...


  • @marceloaqno I am also recompiling and testing.
    thanks for the (hopeful) fix
    I will report back with my status in a few days

  • @marceloaqno :

    At first, THANKS for your help. CPU usage does not rise anymore.
    But unfortunately no more node READs after the same situation:

    Mar  4 07:00:09 raspiez mysgw: TSF:MSG:READ,14-14-0,s=255,c=3,t=6,pt=1,l=1,sg=0:0
    Mar  4 07:00:09 raspiez mysgw: TSF:MSG:READ,12-12-0,s=255,c=3,t=6,pt=1,l=1,sg=0:0
    Mar  4 07:00:09 raspiez mysgw: GWT:RFC:C=1,MSG=14;255;3;0;6;M
    Mar  4 07:00:09 raspiez mysgw: !TSF:MSG:SEND,0-0-14-14,s=255,c=3,t=6,pt=0,l=1,sg=0,ft=0,st=NACK:M
    Mar  4 07:00:09 raspiez mysgw: TSF:MSG:READ,11-11-0,s=255,c=0,t=18,pt=0,l=3,sg=0:1.5
    Mar  4 07:00:09 raspiez mysgw: GWT:RFC:C=1,MSG=12;255;3;0;6;M
    Mar  4 07:00:09 raspiez mysgw: TSF:MSG:SEND,0-0-12-12,s=255,c=3,t=6,pt=0,l=1,sg=0,ft=0,st=OK:M
    Mar  4 07:00:13 raspiez mysgw: TSM:READY:NWD REQ
    Mar  4 07:00:13 raspiez mysgw: TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=20,pt=0,l=0,sg=0,ft=0,st=OK:
    Mar  4 07:00:13 raspiez mysgw: TSF:SRT:OK
    Mar  4 07:00:13 raspiez mysgw: TSF:SAN:OK
    Mar  4 07:00:37 raspiez mysgw: Ethernet client disconnected.
    Mar  4 07:00:37 raspiez mysgw: New connection from
    Mar  4 07:00:37 raspiez mysgw: GWT:TSA:C=0,CONNECTED
    Mar  4 07:00:37 raspiez mysgw: GWT:TSA:C=1,DISCONNECTED

    After this point (again after a reconnect from the controller) no more messages from any node PLUS the cpu usage stayed normal (what makes it even worse at this moment, as I would have to create a script which monitors the logfile and restarts the mysgw service in this situation). As soon as the service is restarted, everything is working fine again.

    What happens after this point in the log:

    Mar  4 07:00:37 raspiez mysgw: GWT:RFC:C=0,MSG=0;0;3;0;2;
    Mar  4 07:15:13 raspiez mysgw: TSF:SAN:OK
    Mar  4 07:20:13 raspiez mysgw: TSM:READY:NWD REQ
    Mar  4 07:20:13 raspiez mysgw: TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=20,pt=0,l=0,sg=0,ft=0,st=OK:
    Mar  4 07:30:13 raspiez mysgw: TSF:SRT:OK
    Mar  4 07:30:13 raspiez mysgw: TSF:SAN:OK
    Mar  4 07:30:37 raspiez mysgw: GWT:TSA:C=0,DISCONNECTED
    Mar  4 07:30:37 raspiez mysgw: Ethernet client disconnected.
    Mar  4 07:30:37 raspiez mysgw: New connection from
    Mar  4 07:30:37 raspiez mysgw: GWT:TSA:C=0,CONNECTED
    Mar  4 07:30:37 raspiez mysgw: GWT:RFC:C=0,MSG=0;0;3;0;2;
    Mar  4 07:40:13 raspiez mysgw: TSM:READY:NWD REQ
    Mar  4 07:40:13 raspiez mysgw: TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=20,pt=0,l=0,sg=0,ft=0,st=OK:
    Mar  4 07:45:13 raspiez mysgw: TSF:SAN:OK
    Mar  4 08:00:13 raspiez mysgw: TSM:READY:NWD REQ
    Mar  4 08:00:13 raspiez mysgw: TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=20,pt=0,l=0,sg=0,ft=0,st=OK:
    Mar  4 08:00:13 raspiez mysgw: TSF:SRT:OK
    Mar  4 08:00:13 raspiez mysgw: TSF:SAN:OK
    Mar  4 08:00:37 raspiez mysgw: GWT:TSA:C=0,DISCONNECTED
    Mar  4 08:00:37 raspiez mysgw: Ethernet client disconnected.
    Mar  4 08:00:37 raspiez mysgw: New connection from
    Mar  4 08:00:37 raspiez mysgw: GWT:TSA:C=0,CONNECTED

    and so on....

    It seems that the increasing cpu usage is only a symptom for the real problem.
    As I am using this in production I will dis-apply the patch and use the daemon as before (beacuse using the python script for cpu-usage-monitoring makes the situation somehow controllable for me).
    Maybe you could have an additional eye on this please? Could I help you with further information? Maybe I could add some additional logging somewhere in the code?

    Thanks again and cheers,

  • Code Contributor

    @otto001 I'm trying to reproduce this problem, but so far I've got nothing beyond the normal behavior of mysgw.
    I tried with a RPi1 and RPi3 using the fhem controller with the latest raspbian.

  • @marceloaqno said in 💬 Building a Raspberry Pi Gateway:

    @otto001 I'm trying to reproduce this problem, but so far I've got nothing beyond the normal behavior of mysgw.
    I tried with a RPi1 and RPi3 using the fhem controller with the latest raspbian.

    My uptime is at 4 days now. so far still working with your patch. CPU is at 2% and sensor network still working correctly. will report if that changes.

  • I've been using your restarting method and its been working ok and has done one restart in 5 days.
    However I now see something else where altho cpu use is fine, none of my nodes can communicate to the gateway. My controller can connect to the gateway no problem but there are no messages received. Restarting nodes does not help. Only a manual restart of the gateway gets things going again - at least for a while anyway.
    Where is the log output from the gateway to be found? I know it can be run from the bash prompt to write the output to screen but how about logging the installed service output?

  • Mod

    @nick-willis the log is sent to syslog by default. See https://www.mysensors.org/build/raspberry#troubleshooting for details.

  • @marceloaqno : This is strange. I am using a RPi 1 on this gateway with raspbian Jessie. Beside the GW-service there is only a small python programm which listens on an UPD-Port and plays an mp3 if it receives suitable data (for doorbell). Since March 4, 20:15 there were several restarts due to high cpu usage (after dis-applying your patch):

    2018-03-04 23:01:03 cpu (99.7) very high! --> restarting service
    2018-03-05 07:31:03 cpu (99.7) very high! --> restarting service
    2018-03-05 11:01:03 cpu (98.7) very high! --> restarting service
    2018-03-05 13:31:04 cpu (94.7) very high! --> restarting service
    2018-03-06 11:31:03 cpu (99.7) very high! --> restarting service
    2018-03-06 12:31:03 cpu (98.7) very high! --> restarting service
    2018-03-07 06:01:03 cpu (94.8) very high! --> restarting service
    2018-03-07 22:31:03 cpu (99.8) very high! --> restarting service

    With this "auto-restarts" the sensors are working fine, I did not notice any problems.

    However, I just upgraded to the recent Stretch (what takes a LONG time on RPi 1 and made me struggle a little bit with the new network names). I also rebuilt the GW of course and will report here what will happen....

    @Nick-Willis : did you apply the patch of marceloaqno or not? Did you enable debugging? (see here )


  • Code Contributor

    @otto001 In a new attempt to trigger this problem, I am using a script that will force the fhem controller to reconnect every 30s to the gateway (built with mysensors master branch, unpatched), and sends me a note in case of high CPU usage:

    I'll leave it running for a few days to see what happens.

    Here is the script, if anyone is interested:

    while true; do
      (echo "set mysgw disconnect"; echo "quit") | telnet localhost 7072 > /dev/null 2>&1
      sleep 1
      (echo "set mysgw connect"; echo "quit") | telnet localhost 7072 > /dev/null 2>&1
      sleep 1
      cpu_percent=$(ps -C "mysgw" -o %cpu=)
      if [ "$cpu_percent" -ge 90 ]
        echo "ALERT: HIGH CPU USAGE"
        # pushbullet script from https://gist.github.com/outadoc/189bd3ccbf5d6e0f39e4
        /home/pi/pushbullet.sh "RPi1: HIGH CPU USAGE"
      sleep 30

  • @marceloaqno : Thank you!
    Just a notice: I do NOT disconnect, I just connect every 30 minutes. Has been working for me since more than 2 years (ancient ms-gw version on RPi).

    Yesterday I did a dist-upgrade to stretch on the "problematic" gw (as mentioned above) - without your patch but with my monitoring-script running. It is a little bit to early I presume, but no high cpu problems so far. I will report back here in a few days. Maybe this problem is really related to old libraries or something?! If this is running stable for a few days I will apply your patch and see what happens.
    Thanks again!


  • Code Contributor

    @otto001 After a few hours running the reconnect script, I noticed several error messages in my gateway log:

    accept(): Too many open files

    The problem was that the gateway wasn't releasing the socket descriptor after each disconnection of the controller. After reaching the limit (mine was 1036) the controller can't connect.

    I'm not entirely sure that this problem is related to what you're having. You can check how many file descriptors currently opened by the gateway with the command below

    sudo lsof -u root |grep mysgw |wc -l

    The fix:

  • How do I update from master branch to development branch?

  • Mod

    Why do you want to do that? Development version is still work in progress

  • I'm using a raspberry pi gateway in home-assistant.
    Sometimes my gateway doesn't work anymore, and when I restart the service, it is running good
    I used ./configure --my-transport=nrf24 --my-rf24-irq-pin=15 --my-gateway=ethernet --my-port=5003

  • Mod

    Read the article again, there is the instruction on how to download the development version, but before you have to uninstall the mysgw service and rename the current mysensors folder to keep as backup.

  • Code Contributor

    @gieljnssns The fixes I mentioned above haven't yet been applied to the development branch. Eventually they will be, but I'm still doing some testing.

  • @marceloaqno :
    Thank you!!! Should this patch be applied together with your first patch?
    After some days without problems on the newest raspbian packages the gw hung again, but WITHOUT high cpu usage (and WITHOUT your first patch applied). There were just no more reads from the sensors in the log, only the re-connects of fhem. After restarting the service, everything is fine again.
    Unfortunately I did see your post after that 😞
    But I checked the log and could not find the words "too" or "Too" in the log (running service with -d).
    Some minutes after restarting I checked how many open files there were with the command you supplied: 21

    In the meantime I have created a small udp listening service which restarts the service if a certain string is received, so I can restart the service by double-clicking one of my switches without the need of login to the gw (also for the wife)....

    @gieljnssns : I think you are experiencing exactly the same problem we are discussing 🙂

    Thanks again!

  • Mod

    I'm using dietpi and I am not having big issues even running 2 gateway instances with 2 different radios

  • Code Contributor

    @otto001 The second patch can be applied without the first one.

  • @gohan :
    dietpi looks interesting! did not know about this yet.
    what hardware are you using? and what version of mysgw?

  • @marceloaqno :
    THANKS! Just applied your patch.
    I will report in a few days when I can see if the problem is solved...

  • Can someone tell me how to apply this patch?

  • Mod

    @otto001 normal rpi3 and mysgw 2.2

  • I need help with my Rpi mqtt-gw.
    I tried to get dev-branch working but changed now to stable. All the install routines run without problems. The service just doesn't seem to work and I can't figure out why.

    1. Rpi W, Raspbian wheezy, nRF24-PA, MQTT-gw, Mosquitto and Openhab2 on same board
    1521010232: New connection from on port 1883.
    1521010232: New client connected from as mygateway1 (c1, k15, u'xxxx').
    1521010232: Socket error on client mygateway1, disconnecting.


    Mar 14 08:51:02 GwMqOH2 systemd[1]: Starting MySensors Gateway daemon...
    Mar 14 08:51:02 GwMqOH2 systemd[1]: Started MySensors Gateway daemon.
    Mar 14 08:51:03 GwMqOH2 mysgw: Starting gateway...
    Mar 14 08:51:03 GwMqOH2 mysgw: Protocol version - 2.2.0
    Mar 14 08:51:03 GwMqOH2 mysgw: MCO:BGN:INIT GW,CP=RNNGLSQX,VER=2.2.0
    Mar 14 08:51:03 GwMqOH2 mysgw: TSF:LRT:OK
    Mar 14 08:51:03 GwMqOH2 mysgw: TSM:INIT
    Mar 14 08:51:03 GwMqOH2 mysgw: TSF:WUR:MS=0
    Mar 14 08:51:03 GwMqOH2 mysgw: TSM:INIT:TSP OK
    Mar 14 08:51:03 GwMqOH2 mysgw: TSM:INIT:GW MODE
    Mar 14 08:51:03 GwMqOH2 mysgw: TSM:READY:ID=0,PAR=0,DIS=0
    Mar 14 08:51:03 GwMqOH2 mysgw: MCO:REG:NOT NEEDED
    Mar 14 08:51:03 GwMqOH2 mysgw: MCO:BGN:STP
    Mar 14 08:51:03 GwMqOH2 mysgw: MCO:BGN:INIT OK,TSP=1
    Mar 14 08:51:03 GwMqOH2 mysgw: GWT:RMQ:MQTT RECONNECT
    Mar 14 08:51:03 GwMqOH2 mysgw: connected to
    Mar 14 08:51:03 GwMqOH2 mysgw: GWT:RMQ:MQTT CONNECTED
    Mar 14 08:51:03 GwMqOH2 mysgw: GWT:TPS:TOPIC=mysensors-out/0/255/0/0/18,MSG SENT
    Mar 14 08:51:03 GwMqOH2 systemd[1]: mysgw.service: main process exited, code=killed, status=11/SEGV
    Mar 14 08:51:03 GwMqOH2 systemd[1]: Unit mysgw.service entered failed state```
    GW configure-line:

    ./configure --my-transport=nrf24 --my-gateway=mqtt --my-controller-ip-address= --my-mqtt-publish-topic-prefix=mysensors-out --my-mqtt-subscribe-topic-prefix=mysensors-in --my-mqtt-client-id=mygateway1 --my-rf24-irq-pin=15 --my-leds-err-pin=12 --my-leds-rx-pin=16 --my-leds-tx-pin=18 --my-mqtt-user=xxxx --my-mqtt-password=yyyyy --my-signing=password --my-signing-password=zzzzzz```

    I have checked mosquitto has correct user-pw combination, but what should I check next? Help!

  • Mod

    @masmat said in 💬 Building a Raspberry Pi Gateway:


    Do you have another client named mygateway1 connecting to mqtt? Try changing it to a different name just to play safe

  • @gohan Can I just edit mysgw.cpp and do "daemon-reload"?
    I have just this one gw. And openHab2 but that has a different id.

  • Mod

    No, you need to recompile it again in case you make that change. Have you ever tried dietpi for RPI?

  • @gohan OK. I did that, the same socket error remains in Mosquitto just under new id.
    Is my syntax correct or am I somehow having problems with mosquitto user-pw...?

    Haven't tried DietPi. Would Mys+Mosquitto+Openhab2 have trouble running on it? Or why should I change to it?

  • Mod

    have you tried connecting with another mqtt client like mqttfx to see if everything is working?

  • Code Contributor

    @masmat What is the mqtt broker / version you are using?

  • Code Contributor

    @gieljnssns One way is to replace the changed files, in this case EthernetServer.cpp for the first patch and EthernetClient.cpp for the second patch.

    You can download from:

    Here is a step-by-step:

    git clone https://github.com/mysensors/MySensors.git
    cd MySensors
    curl https://raw.githubusercontent.com/marceloaqno/MySensors/linux-fix-stability/drivers/Linux/EthernetServer.cpp -o drivers/Linux/EthernetServer.cpp
    curl https://raw.githubusercontent.com/marceloaqno/MySensors/linux-fix-stability/drivers/Linux/EthernetClient.cpp -o drivers/Linux/EthernetClient.cpp

    from here just run ./configure with your options and then make

  • @marceloaqno Mosquitto v1.4.14.
    The broker is working, at least sending & receiving command line (_sub & _pub) messages.

Log in to reply

Suggested Topics

  • 28
  • 99
  • 158
  • 27
  • 55
  • 344
  • 89
  • 51